imiryakubov
?>

Алиса решила отправить Бобу сообщение. Но сейчас идет урок информатики, и просто так передать Бобу записку с текстом нельзя. Поэтому Алиса решила скрыть свое сообщение в массиве целых положительных чисел и передать Бобу этот массив в надежде, что Боб сможет извлечь из этого массива ее сообщение. Каждое переданное Алисой число содержит в своем младшем байте ASCII-код некоторой буквы (большой или маленькой) английского алфавита. Напишите программу, которая Бобу прочитать сообщение Алисы. В первой строке входных данных содержится единственное натуральное число N (1 ≤ N ≤ 1000) - количество чисел в переданном массиве. Во второй строке входных данных содержаться N положительных целых чисел Ai, каждое из которых не превышает 109 и содержит в своем младшем байте ASCII-код некоторой буквы английского алфавита. Выведите единственную строку, состоящую ровно из N букв, скрытых в переданном Алисой массиве.

Информатика

Ответы

djikia88

Бегин

вар n:=ReadInteger('Количество хромосом/кол-во подбородков:');

врайтэлен там сам дальше.

 вар a:=MatrRandom(n,n,-99,99);

 a.Println(4); Врайтлн(n*4*'-');

вар типо кушать варишь b:=a.Rows.Select(row->row.Where(t->t.IsOdd).DefaultIfEmpty.Average)

   .Toаррай;

 b.Println;

энд типо конец.

Пример

Количество сам найдёшь/столбцов в матрице: около 5-20 там по месецам нужно смотреть.

*** Исходная попа (нужно сначало её помыть, потом начинать работу) ***

 40 -38  16 -70  26 50 21 43 1323 123  123

 87   7 -31  99  34 345 345 645 645 64 645

-34 -47 -33  32  56 456 4564 6 46 54 6456

 66  71  41   7  80 456 4564 6456 45  64

 55  42 -22   7  86 45645 4  456 45 64 46

0 40.5 -40 39.6666666666667 3112 312312 3123

Объяснение:

.

Tkachenko1050

Глупый человек на ответе.

Сейчас всё объясню :

Нам нужно всего ввести в паскаль код:

program name

begin : a ('Число")

Random: False

True ; Fu

Writlen ; Ck

Del: U mother

N (1 ≤ N ≤ 1000)

end.

Объяснение:

В паскале всё  очень просто,порой просто,нужно включить логику.

slspam
С информационными процессами в технике мы сталкиваемся постоянно,ребенок, когда играем с управляемым автомобилем или кораблем получает первое знакомство с информационными процессами в технике. Наука создала в конце века роботы - автоматические механизмы, управляемые компьютером. Они применяются там, где присутствие человека бывает сложным или невозможным действием. Роботы оснащены видиокамерами, приборами для изучения климата. Переключение программ телевизора, изменение уровня громкости,установка режима работы СВЧ и т.д. все это информационные процессы происходящие в технике. В физике, которая изучает неживую природу, информация является мерой упорядоченности системы по шкале«хаос - порядок. Один из основных законов классической физики утверждает, что замкнутые системы, в которых отсутствует обмен веществом и энергией с окружающей средой, стремятся с течением времени перейти из менее вероятного упорядоченного состояния в наиболее вероятное хаотическое состояние.
kukoleva
Условие попадания точки в полукруг можно записать в виде
\begin {cases} x \geq 0 \\ x^2+y^2 \leq R^2 \end {cases}

#include <iostream>

using namespace std;

int main(){
    float x,y,R;
    cout<<"Vvedite a,b,R\n";
    cin>>x>>y>>R;
    if (x>=0 && x*x+y*y<=R*R)
        cout<<"\nPopadaet\n";
    else
        cout<<"\nNe popadaet\n";
}

Тестовое решение:
Vvedite a,b,R
3
5
7

Popadaet

--------------------------------
Process exited after 15.45 seconds with return value 0
Для продолжения нажмите любую клавишу . . .

Vvedite a,b,R
4
-2
3

Ne popadaet

--------------------------------
Process exited after 27.79 seconds with return value 0
Для продолжения нажмите любую клавишу . . .

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Алиса решила отправить Бобу сообщение. Но сейчас идет урок информатики, и просто так передать Бобу записку с текстом нельзя. Поэтому Алиса решила скрыть свое сообщение в массиве целых положительных чисел и передать Бобу этот массив в надежде, что Боб сможет извлечь из этого массива ее сообщение. Каждое переданное Алисой число содержит в своем младшем байте ASCII-код некоторой буквы (большой или маленькой) английского алфавита. Напишите программу, которая Бобу прочитать сообщение Алисы. В первой строке входных данных содержится единственное натуральное число N (1 ≤ N ≤ 1000) - количество чисел в переданном массиве. Во второй строке входных данных содержаться N положительных целых чисел Ai, каждое из которых не превышает 109 и содержит в своем младшем байте ASCII-код некоторой буквы английского алфавита. Выведите единственную строку, состоящую ровно из N букв, скрытых в переданном Алисой массиве.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

спец Михасов
Ионов202
карпова581
kgrechin
dashanna04225
Чиркина999
luza5
pannotolstova488
aivia29
iordanekaterina
kun1969
md-masya
SEMENOV25352
zakupka-marion
nata27-73589
▲