agaltsova86
?>

C++. напишите программу, которая из последовательности чисел ищет и выводит те, которые оканчиваются на 3

Информатика

Ответы

tyrnaus
#include <iostream>
using namespace std;
int main()
{
int n,a;
cin>>n;
for(int i=0;i<n;i++)
{
cin>>a;
if(a % 10==3) cout<<a<<endl;
}
return 0;
}
Лусине_Ильенков134
#include <bits/stdc++.h>
using namespace std;
int main()
{
int ct;
cin >> ct;
for(int i = 1; i <= ct; ++i){
int num;
cin >> num;
if(num % 10 == 3){
cout << num << " ";
}
}
return 0;
}
sarbaevmax
Используем формулу Герона для нахождения площади треугольника по трем сторонам: S=√(p·(p-a)·(p-b)·(p-c)), где p - полупериметр, равный
p=(a+b+c)/2

Программа:

program z;
var a1,b1,c1,a2,b2,c2,p1,p2,s1,s2:real;
begin
readln(a1,b1,c1);   {ввод длин сторон первого треугольника}
p1:=(a1+b1+c1)/2; {полупериметр первого треугольника}
s1:=sqrt(p1*(p1-a1)*(p1-b1)*(p1-c1)); {площадь первого треугольника}

readln(a2,b2,c2);  {ввод длин сторон второго треугольника}
p2:=(a2+b2+c2)/2; {полупериметр второго треугольника}
s2:=sqrt(p2*(p2-a2)*(p2-b2)*(p2-c2)); {площадь второго треугольника}
if s1=s2                   {если площади треугольников равны}
then writeln('Yes')   {то вывести положительный ответ}
else writeln('No');    {иначе вывести отрицательный ответ}
end.
Поликарпова-Мазурова
Судя по названию функций, речь идет об операции деления по модулю (остаток от деления, она обозначается как %).
По условию задания не очевидно, что является делителем, а что делимым, поэтому в решении будут рассмотрены оба варианта.

Немного теории. Если a делимое и b делитель, то существуют единственные q и r, такие что:
a = b * q + r; где a, b, q, r  - целые числа, и b не равно 0, 0 <= r < |b|.
То есть, если мы подобрали такие q и r, что выполняется условие, то это значит что они единственные и верные.

Вначале будет рассмотрен вариант, где второй аргумент функции делится на первый аргумент функции.

mod(-7,87) = 87 % (-7) = 3 . Проверка: 87 = (-7)*q + r = (-7)*(-12) + 3.
mod(10,99) = 9. Проверка: 99 = 10 * 9 + 9.
mod(-7,-13) = 1. Проверка: -13 = (-7) * q + r = (-7)*2 + 1.

Далее рассматривается вариант, когда первый аргумент функции делится на второй аргумент.
a = b * q + r.

mod(-7,87) = -7 % 87 = 80. Проверка: -7 = 87 * (-1) + 80.
mod(10,99) = 10. Проверка: 10 = 99 * 0 + 10.
mod(-7,-13)=-7 % - 13 = 6. Проверка: -7 = -13 * 1 + 6.

П.С. На калькуляторы в Интернете не ориентируйтесь, они не корректно обрабатывают такие выражения.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C++. напишите программу, которая из последовательности чисел ищет и выводит те, которые оканчиваются на 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

davidovalbert6
tarigor
egoryuzbashev
dokmak140652
kotsur
Хохлова Иванович
elav20134518
dilanarthur27
svetlanam81
bronco-s
ivanjeka87
saint158
vladislavk-market2
atvkaprolon
Aleksei368