verynzik66525
?>

РЕШИТЬ ЗАДАЧУ НА С++ Требуется написать программу, которая определяет и выводит сумму только положительных из трёх данных чисел a, b и c. Формат входных данных Входной поток содержит три целых числа в одной строке — a, b и c (∣∣a∣∣, ∣∣b∣∣, ∣∣c∣∣≤5⋅108 Формат выходных данных Выведите одно число — искомую сумму. входные данные 5 -5 1 выходные данные 6

Информатика

Ответы

koxhulya61

#include <iostream>

using namespace std;

int main()

{

   int a, b, c;

   int amount = 0;

   cin >> a >> b >> c;

   if (a > 0)

   {

       amount += a;

   }

   if (b > 0)

   {

       amount += b;

   }

   if (c > 0)

   {

       amount += c;

   }

   cout << amount;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int a, b, c;  // Создание целочисленных переменных a, b, c

   int amount = 0;  // Создание целочисленной переменной amount, которая будет хранить сумму положительных чисел. Значение переменной = 0

   cin >> a >> b >> c;  // Ввод с клавиатуры значений переменных a, b, c

   if (a > 0)  // Если значение переменной a > 0

   {

       amount += a;  // К значению переменной amount прибавляем значение переменной a

   }

   if (b > 0)  // Если значение переменной b > 0

   {

       amount += b;  // К значению переменной amount прибавляем значение переменной b

   }

   if (c > 0)  // Если значение переменной b > 0

   {

       amount += c;  // К значению переменной amount прибавляем значение переменной c

   }

   cout << amount;  // Вывод значения переменной amount

}

vedaikin
1. В "реальном мире" это решается примерно так:

// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
begin
  var a:=ArrRandom(ReadInteger('n='),0,2); a.Println;
  a.Sorted.Println
end.

Тестовое решение:
n= 15
1 2 0 2 2 0 2 0 2 0 0 1 0 0 2
0 0 0 0 0 0 0 1 1 2 2 2 2 2 2

2. Но, поскольку считается, что школьникам больше заняться нечем, их заставляют писать примерно в таком стиле (и время займет, и ощибок понаделают):

// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
const
  nn=100;
var
  i,j,n,t:integer;
  a:array[1..nn] of integer;
begin
  Write('n='); Read(n);
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(3);
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-1 do
      if a[j]>a[j+1] then begin
        t:=a[j]; a[j]:=a[j+1]; a[j+1]:=t
        end;
  for i:=1 to n do Write(a[i],' ');
  Writeln;
end.

Тестовое решение:
n=15
0 1 1 0 2 1 0 2 1 2 1 0 0 2 0
0 0 0 0 0 0 1 1 1 1 1 2 2 2 2
lugowskayatania2017
Начнём с того, чтобы создавать презентацию в MSPowerPoint, необходимо создать слайды во вкладке "Главное" где в левом верхнем углу будет окошко создания слайда, где можно также выбрать шаблон желаемого слайда (титульный),Далее создав определённое количество слайдов мы можем приступить к работе с ними (Программа PowerPoint Обладает широкимфункционалом визуальных функций, чтобы привлекать внимание зрителя), мы можем вставить: звук,картинки,диаграммы,таблицы,видеоклипы и т.д.( и впоследствии настраивать их:воспроизведение,отображение)Можно настроит задний фон для слайдов(можно выбрать из списка шаблонов), и их анимацию для каждого по отдельности(это придаст интереса при просмотре)
Запишите основные этапы создания презентации
Запишите основные этапы создания презентации

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕШИТЬ ЗАДАЧУ НА С++ Требуется написать программу, которая определяет и выводит сумму только положительных из трёх данных чисел a, b и c. Формат входных данных Входной поток содержит три целых числа в одной строке — a, b и c (∣∣a∣∣, ∣∣b∣∣, ∣∣c∣∣≤5⋅108 Формат выходных данных Выведите одно число — искомую сумму. входные данные 5 -5 1 выходные данные 6
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Stanislavovna1237
danceplusru
Nikolaevich-Svetlana388
eoils-info
Vasileva
Vladimir-Tamara1359
Yuliya mikhail
Мусаев Игоревич371
Есартия52
taanaami75
seleznev1980
izykova22
Nikita
zaschitin48
Павел_Перелыгин