d111180
?>

Подсчитать количество целых чисел в диапазоне от 100 до 999 у которых есть две одинаковые цифры. ЖЕЛАТЕТЬЛО НА ПИТОНЕ

Информатика

Ответы

cmdkotelniki

num = int(input("число: "))

sum = 0

while (num != 0):

   sum = sum + num % 10

   num = num // 10

print("сумма цифр равна: ", sum)

с 100 получилось 1

а с 999 получилось 27

martinson1136
2^2018 в двоичной системе есть единица и 2018 нулей. 2018=2048-32+2
(исходное выражение трансформировалось в 2^2018-2048+32-2)
2048=2^11 (единица и 11 нулей)
32=2^5 (единица и 5 нулей)
2=10 :)
Для начала прибавлю к 2^2018 100000. Получится число, у которого (с конца) 5 нулей, затем единица, затем идут 2012 нулей и снова единица.
Теперь буду вычитать 2 т .е. 100...100000-10. Займу единицу с шестой с конца позиции. Будет 100...011110. Теперь нужно вычитать из этого числа 2^11. Последние 11 позиций не изменятся (вычитаются нули), а вот для вычета единицы потребуется "зянять" её у самой первой цифры числа. Если нарисовать последние 12 цифр исходного числа, картинка будет следующая: 
1...000000011110
-   100000000000

0...111111111110
Осталось узнать, сколько единичек стояло на месте многоточия. В 2^11 было 12 цифр, соответственно, получаем 2018-12=2006 позиций, на которых стоят нули. К этим позициям нужно добавить 11 единиц, которые видны в "столбике".
Итого 2006+11=2017 единиц\
P.S. если понятен принцип решения, советую перерешить еще раз, потому что у меня очень плохо с арифметикой. 

***
Есть очень хорошее свойство: некое десятичное число n^m в переводе в n-ичную систему счисления будет в этой системе счисления выглядеть как единица и m нулей. Свойство довольно очевидное: при переводе из десятичной системы в n-ичную мы исходное число будем делить на n, т.е. получим остаток от деления 0 и частное n^(m-1). И так будет продолжаться m раз, пока мы не разделим число само на себя и получим единицу в последнем частном. Отсюда 1 и m нулей.
secretar62
Program Primer;
var
m,g:Integer;
begin
Write('Введите год: ');
ReadLn(g);
Write('Введите номер месяца: ');
ReadLn(m);
if (g mod 4=0) and (m=2)
then WriteLn('В феврале ',g,' года 29 дней')
else
case m of
1: WriteLn('В январе 31 день');
2: WriteLn('В феврале 28 дней');
3: WriteLn('В марте 31 день');
4: WriteLn('В апреле 30 дней');
5: WriteLn('В мае 31 день');
6: WriteLn('В июне 30 дней');
7: WriteLn('В июле 31 день');
8: WriteLn('В августе 31 день');
9: WriteLn('В сентябре 30 дней');
10: WriteLn('В октябре 31 день');
11: WriteLn('В ноябре 30 дней');
12: WriteLn('В декабре 31 день')
else WriteLn('Такого месяца не существует');
end;
end.
По заданному году g и номера месяца m определите количество дней в месяце. это нужно делать в паскал

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Подсчитать количество целых чисел в диапазоне от 100 до 999 у которых есть две одинаковые цифры. ЖЕЛАТЕТЬЛО НА ПИТОНЕ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

secretar62
P7Y7V7
dpodstrel85
Vs1377
Владимирович_Намик59
potapin
Pervosha
Alekseevna1811
blizzardtap641
Маргарита1091
Nefedova1432
lenalevmax7937
Лоскутова
ekattatarenko
Sergeevich-irina