Михайлович_гергиевич315
?>

Практическая работа № 8. Тема. Програмирование линейных алгоритмов. Цель: научиться составлять, компелировать , запускать на выполнения линейные программы на языке Паскаль. Оборудование: ПК «Celeron» Задание: 1.Познакомится с работою в среде програмирования Turbo Pascal. 2. Решить задачу(составить блок-схему и программу на языке программирования Turbo Pascal. Условие задачи: Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры. Исходные данные. a – стоимость перчаток; b – стоимость портфеля; d – стоимость галстука; den – количество денег у человека. Все эти переменные будут вещественного типа. Результат. ostatok – количество денег, которое остается у человека(вещественный тип) ostatok:=den-a-b-d как мне правильно написать вывод этой практической?

Информатика

Ответы

alvs9
1. Современный вариант (так можно писать):

// PascalABC.NET 3.1, сборка 1184 от 02.03.2016
begin
  var n:=10;
  var a:=ArrRandom(n,1,99); Print('A:'); a.Println;
  var b:=ArrRandom(n,1,99); Print('B:'); b.Println;
  var x:=a.Zip(b,(p,q)->p*q); Print('X:'); x.Println;
  Writeln('min(X)=',x.Min)
end.

Тестовое решение:
A: 34 37 41 26 78 10 13 15 59 71
B: 70 49 56 94 79 25 72 54 39 34
X: 2380 1813 2296 2444 6162 250 936 810 2301 2414
min(X)=250

2. "Школьный вариант" (так учат в школе, чтобы жизнь медом не казалась, но может быть, что учителя сами не понимают современные технологии программирования):

// PascalABC.NET 3.1, сборка 1184 от 02.03.2016
const
  n=10;
var
  a,b,x:array[1..n] of integer;
  i,min:integer;
begin
  Randomize;
  Write('A: ');
  for i:=1 to n do begin
    a[i]:=Random(99)+1; Write(a[i],' ')
    end;
  Writeln;
  Write('B: ');
  for i:=1 to n do begin
    b[i]:=Random(99)+1; Write(b[i],' ')
    end;
  Writeln;
  Write('X: ');
  min:=100*100; // больше максимального
  for i:=1 to n do begin
    x[i]:=a[i]*b[i]; Write(x[i],' ');
    if min>x[i] then min:=x[i]
    end;
  Writeln;
  Writeln('min(X)=',min)
end.

Тестовое решение:
A: 43 52 75 74 18 57 39 67 44 20
B: 33 16 36 34 65 9 42 51 79 36
X: 1419 832 2700 2516 1170 513 1638 3417 3476 720
min(X)=513
kap393
Задача №1

//Pascal
var x,y:real;
begin
  readln(x,y);
  if (x>0) and (y>0) then writeln('I четверть');
  if (x<0) and (y>0) then writeln('II четверть');
  if (x<0) and (y<0) then writeln('III четверть');
  if (x>0) and (y<0) then writeln('VI четверть');
end;
 
Задача №2

//Pascal
var a:integer;
begin
  readln(a);
  if a mod 2 =0 then writeln(' Четное')
  else writeln(' Нечетное');
  if a mod 10 =7 then writeln(' оканчивается на 7')
  else writeln(' не оканчивается на 7 ');
  if a mod 5 =0 then writeln(' делится на 5 ')
  else writeln(' не делится на 5');
 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Практическая работа № 8. Тема. Програмирование линейных алгоритмов. Цель: научиться составлять, компелировать , запускать на выполнения линейные программы на языке Паскаль. Оборудование: ПК «Celeron» Задание: 1.Познакомится с работою в среде програмирования Turbo Pascal. 2. Решить задачу(составить блок-схему и программу на языке программирования Turbo Pascal. Условие задачи: Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры. Исходные данные. a – стоимость перчаток; b – стоимость портфеля; d – стоимость галстука; den – количество денег у человека. Все эти переменные будут вещественного типа. Результат. ostatok – количество денег, которое остается у человека(вещественный тип) ostatok:=den-a-b-d как мне правильно написать вывод этой практической?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AndrukhovichKonovalov
gusinica23
best00
Alexander2035
Komarovsergeysk
Головин662
bugaevnicky
Петренко1852
Артур
Arsen-araqelyan20164
egorova90356684858370
ea-office
verakmves
YuREVICh646
yda659