Далее считаем объем, занимаемый иллюстрациями:
2520*3=7560 мегабайт. Делим на 1024 и получаем 7,3828125 гигабайт.
Складываем полученные суммы: 1+7,3828125=8,3828125 гигабайт. Что превышает объем флеш-карты. Соответственно в несжатом виде «рукопись» не поместится.
2)
а) Из предыдущей задачи мы знаем, что символ кодируется 16 битами. Соответственно, чтобы получить объем, занимаемый одной книгой перемножаем 256*128*64*16=33 554 432 бита = 4 194 304 байта = 4 096 кБ = 4 мегабайта. Чтобы узнать сколько книг поместится на жесткий диск необходимо объем жесткого диска умножить на 1024 (получим объем в мегабайтах): 160 Гбайт *1024 = 163 840 мегабайт. Теперь делим объем жесткого диска на объем одной книги: 163 840 / 4 = 40 960 книг.б) Теперь перемножаем количество книг на 3 сантиметра и получаем высоту стопки книг: 40 960*3=122 880 см.
Поделитесь своими знаниями, ответьте на вопрос:
C++.совершенным называется число, равное сумме всех своих делителей, меньших его самого (например, число 6=1+2+3 напишите программу, которая вводит натуральное число n и определяет, является ли число n совершенным.
using namespace std;
bool perfect_number(int n)
{
int res = 1;
for (int i = 2; i * i <= n; ++i)
if (n % i == 0)
res += i + n / i;
return res == n?1:0;
}
int main()
{
int n;
cin >> n;
cout << perfect_number(n)?"YES":"NO";
}