bergamon
?>

Напишите программу, которая определяет сколько раз встречается максимальное число в и-той последовательности, ограниченная n значением. при этом каждое вводимое число должно храниться в памяти компьютера.

Информатика

Ответы

daskal83
//Pascal
var
  A: array of integer;
  i, n, MAX, tmpCount: integer;
begin
  write('Введите n = '); read(n);
  SetLength(A, n);
  MAX := 0;
  for i := 0 to n-1 do
  begin
    write('A[', i+1, '] = ');
    read(A[i]);
    if A[i] > MAX then
    begin
      tmpCount := 0;
      MAX := A[i];
      tmpCount := tmpCount + 1;
    end
    else
    if A[i] = MAX then tmpCount := tmpCount + 1;
  end;
  writeln('Максимальное число ',MAX,' встречается ',tmpCount,' раз.'); 
readln;
end.
alexeylipatov

Объяснение:

Я думаю это майкрасофт ведь он создал персональные компьютеры, игровые приставки и т.п.

 C 2012 года производит собственный планшетный компьютер — Surface. Продукция Microsoft продаётся более чем в 80 странах мира, программы переведены более чем на 45 языков.

Штаб-квартира компании находится в городе Редмонд, штат Вашингтон, США.

Штат сотрудников корпорации на 5 июня 2014 года составляет 127 104 человека[8]. В 2018 году заняла второе место в списке 500 лучших работодателей мира по мнению журнала Forbes[9].

Надеюсь ты оценишь мой ответ ;)

westgti77105
Задание 1.
1) Разрешение 80 dpi показывает, что на каждый дюйм изображения приходится 80 точек. Следовательно, размеры изображения в дюймах составят 320/80 × 640/80 = 4х8 дюймов.
2) Общее количество пикселей составит 320×640 = 204800. Для хранения одного пикселя в палитре из 256=2⁸ цветов потребуется 8 бит = 1 байт. Тогда для хранения всего изображения потребуется 204800×1 = 204800 байт = 204800/1024 = 200 Кбайт

Задание 2.
Высказывание совершенно правильное. Чем больше точек будет содержать каждый дюйм (или сантиметр, миллиметр..) изображения, тем оно будет более подробным, т.е. качественнее.
Разница между «качеством изображения» и «качеством отображения изображения на экране монитора» может быть, а может и не быть - все зависит от того, в какой ситуации рассматривается эта фраза. Если мы говорим любую из этих фраз, оценивая картинку на мониторе, то разницы нет, потому что мы описываем то, что видим. Если же мы под «качеством изображения» имеем в виду разрешение того или иного отображения картинки, т.е. количество дюймов (сантиметров, миллиметров...) которые устройство может отображать, то для монитора оно не превышает 92 dpi, а для принтера составляет минимум 300 dpi, т.е. при одинаковом размере изображения качество напечатанной на принтере картинки более чем втрое выше, чем её отображение на мониторе.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая определяет сколько раз встречается максимальное число в и-той последовательности, ограниченная n значением. при этом каждое вводимое число должно храниться в памяти компьютера.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ПогальниковАлёна589
konstantinslivkov
Александрович Владимирович
hbqhzwtd
hristos1212
abadaeva
tarhan1221
TrofimovAnastasiya828
centrprof20
Жуков219
kononova_Pavel689
Roman343247
laktionova-natal
Daletskaya Sergei1121
mdclcompany
▲