Maria095096
?>

Составьте программу, находящую количество делителей числа х. число х введите с клавиатуры. (pascal abc (не net))

Информатика

Ответы

rebet61
Var n, i, sum: integer; //Описание переменных Begin //Начло программы writeln ('Введите число'); //Диалог с пользователем readln(n); //Считывание числа sum := n; //Присваивание сумме значение самого числа (само число - уже делитель самого себя) writeln('Делители числа:'); //Диалог с пользователем for i := 1 to n div 2 do //Цикл For от до половины n if (n mod i) = 0 then begin //Если число делится на i, то выводим write(i,' '); sum := sum + i; //К значению суммы прибавляем делитель end; //Конец условного оператора if writeln(n); //Вывод самого числа, т.к. оно тоже делитель writeln('Сумма делителей: ',sum); //Вывод суммы делителей End.
marketing6
Program A;var X,sum,i: integer;beginsum := 0 ;Readln(X);for i:= 1 to X doif (X  mod i = 0) then   sum := sum + 1;Writeln(sum);end.
snk7777202
Автор рассказа - Виктор Юзефович Драгунский (1913 - 1972), название рассказа - "Когда я был маленьким".

Главный герой рассказа в детстве плохо пережёвывал пищу и, чтобы поддержать мальчика, во время еды его мама рассказывала сказки. Одной из таких сказок была "Красная Шапочка". Во время рассказа мама напоминала ребёнку хорошенько жевать. После завершения сказки, когда по сюжету охотники разрезали брюхо волку и из него вылезли невредимыми Красная Шапочка и её бабушка, малыш заметил: "Не прожевал, значит, волк-то!" - что противоречило маминым призывам пережёвывать и поэтому звучало особенно забавно.
Леонтьева
Автор рассказа - Виктор Юзефович Драгунский (1913 - 1972), название рассказа - "Когда я был маленьким".

Главный герой рассказа в детстве плохо пережёвывал пищу и, чтобы поддержать мальчика, во время еды его мама рассказывала сказки. Одной из таких сказок была "Красная Шапочка". Во время рассказа мама напоминала ребёнку хорошенько жевать. После завершения сказки, когда по сюжету охотники разрезали брюхо волку и из него вылезли невредимыми Красная Шапочка и её бабушка, малыш заметил: "Не прожевал, значит, волк-то!" - что противоречило маминым призывам пережёвывать и поэтому звучало особенно забавно.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, находящую количество делителей числа х. число х введите с клавиатуры. (pascal abc (не net))
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

karavan85450
MIKhAILOVNAAnton
elenaftdv7
lbondareva
andrewshilin1334
arnika-ooo1
alex091177443
Shikhova-Vitalii1290
РубенШафетдинов
Sergeevich-Novikov
osandulyak
me576
dima0218687
ambstroy
m-zolotukhina2