Rudakova_Yana
?>

1. составьте программу, которая запрашивает с клавиатуры значения x и y. если x> y то печатается разность x-y, в противном случае y-x. 2. напишите программу, которая запрашивает с клавиатуры a, b, c. если a> b+c, то на печать выводится a. в другом случае выводится b+c. 3. напишите программу, которая запрашивает с клавиатуры значения k и x. если k=1, то вычисляется значение sin(x), если k=2, то вычисляется значение cos(x 4. напишите программу, которая запрашивает значения p и m. если p> m2 , то печатается p, в противном случае m2. сделайте в паскале) и можете меня научить ?

Информатика

Ответы

ustinovda14
//Pascal
//1)
var x, y: integer;
begin
write('Введите x y: ');
read(x, y);
if x > y then
writeln(x - y)
else
 writeln(y - x);
end.

//2)
var a, b, c: integer;
begin
write('Введите a b c: ');
read(a, b, c);
if (a > (b + c)) then
writeln(a)
else
writeln(b + c);
end.

//3)
var x, k: integer;
begin
write('Введите x k: ');
read(x, k);
if k = 1 then
writeln(sin(x))
else
if k = 2 then
writeln(cos(x))
else
writeln('k должен быть равен 1 или 2.');
end.

//4)
var p, m: integer;
begin
  write('Введите p, m: ');
  read(p, m);
  if p > m * 2 then
    writeln(p)
  else
    writeln(m * 2);
end.
tonyakuznetsova

1)

const n = 4; m = 4;

var A:array[1..n, 1..m] of integer;

   i, j, iMax, jMax:integer;

begin

 write('Заполнение - Матрица:');

 for i:=1 to n do begin

   for j:=1 to m do begin

     read(a[i, j])

   end;

 end;

 write('Матрица:');

 for i:=1 to n do begin

   writeln;

   for j:=1 to m do begin

     write(a[i, j]:3, ' ');

   end;

 end;

 iMax:=1;

 jMax:=1;

 for i:=1 to n do

   for j:=2 to n do begin

     if a[i, j] > a[iMax, jMax] then begin

       iMax:=i;

       jMax:=j;

     end;

   end;

 writeln;

 writeln('Максимальный элемент: A[', iMax, ', ', jMax, ']=', a[iMax, jMax]);

end.

Вторую не успел сделать, надо уехать.

Объяснение:

diana-020

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   ld a;

   cin >> a;

   if(a > 0)

       a += 20;

   cout << a;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составьте программу, которая запрашивает с клавиатуры значения x и y. если x> y то печатается разность x-y, в противном случае y-x. 2. напишите программу, которая запрашивает с клавиатуры a, b, c. если a> b+c, то на печать выводится a. в другом случае выводится b+c. 3. напишите программу, которая запрашивает с клавиатуры значения k и x. если k=1, то вычисляется значение sin(x), если k=2, то вычисляется значение cos(x 4. напишите программу, которая запрашивает значения p и m. если p> m2 , то печатается p, в противном случае m2. сделайте в паскале) и можете меня научить ?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kuzinnv1968
evsyukov1997
Kalmikova1666
dkedrin74038
Stryapunina
vis-lyubov8832
timpavilion23
daverkieva568
Natakarpova75732
klykovav672
iamhrusha
Svetlana ALLA
S:= 0; m:=5: for i:=2 to m do s:=s+i;
Tatyanaaarzieva72
npdialog66
info126