servik78
?>

Впаскале и только в паскале. 1)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке не убывания. 2)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке убывания , а также выводит количество перестановок. 3)дан массив десяти целых чисел. найти медиану числового ряда. 4) дан массив десяти целых чисел выведите минимальное число массива оканчиговающегося на 4 5) дан массив десяти целых чисел напишите программу которая выводит на экран на экран максимальное число кратное 5.

Информатика

Ответы

Avdeeva Yelizaveta
 1) 
var i,n,k:integer;
 a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  read(a[i]);
 writeln;
 for i:=10 downto 1 do
  write(a[i],' ');
 readln;
 readln
end.
3)
var i,n,k:integer;
a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  read(a[i]);
 writeln;
 writeln((a[5]+a[6])/2:0:2);
 readln;
 readln
end.
4)
var i,n,k,min:integer;
a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  begin
   read(a[i]);
   if (a[i] mod 10=4) or (a[i] mod 10=-4)
    then min:=a[i];

 for i:=1 to 10 do
   if ((a[i] mod 10=4) or (a[i] mod 10=-4)) and (a[i]<min)
    then min:=a[i];
 writeln(min);
end.

5)
 var i,n,k,max:integer;
a:array[1..10] of integer;
begin
 max:=0;
 for i:=1 to 10 do
  begin
   read(a[i]);
   if (a[i] mod 5=0) and (a[i]>max)
    then max:=a[i];
  end;
 writeln(max);
end.
ПолухинаТененева565
 Вот порядок приготовления пельменей. В посуду смешивают яйцо,вода, мука. чуть соли. .Тесто замешивают до консистенции,чтоб можно было резать ножом.  Дальше            Некоторые раскатывают большой сочень потом стаканом  или другой формой выдавливают  лепешечки на посредственно для пельменей туда кладут фарш слепили и готово.                                                                                                          Другие раскатывают тесто под вид колбаски ,затем ножом эту колбаску разрезают на равные части,которые раскатывают для фарша.  Я знаю три вида формы пельменей.
idalbaev

Объяснение: всё дело в том, что в первом случае (в верхнем, где s = 0 написано вне цикла) s изначально равен нулю, а затем с каждой итерацией цикла s увеличивается.

А втором случае на каждой итерации цикла сначала присваивается s = 0, а затем уже изменяется. Поэтому перед каждой следующей итерацией цикла всё что происходило с s раньше обнуляется.

Если подвести итог, то разница заключается в том, что присваивание находится в цикле или вне него, а значит выполняется один раз (если вне цикла) или много раз (если внутри)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Впаскале и только в паскале. 1)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке не убывания. 2)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке убывания , а также выводит количество перестановок. 3)дан массив десяти целых чисел. найти медиану числового ряда. 4) дан массив десяти целых чисел выведите минимальное число массива оканчиговающегося на 4 5) дан массив десяти целых чисел напишите программу которая выводит на экран на экран максимальное число кратное 5.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Coffee3862
Japancosmetica
Vitproficosmetics
Verdievruslan
layna1241383
tatianamatsimoh
isinyakin
natalia595977
nofate1016585
antilopa001
Эдгеева219
Yevgeniya1807
Бурмистрова-Ирина660
menesmir
tarrin-ka