Rufilya-Belov
?>

Составить программу вычисление площади трехгольника выделить целую часть результата и выделить дробную часть

Информатика

Ответы

Yevgenevich775
Var
  S, a, h: real;

begin
 
  write('Введите длину основания --->');read(a);
  write('Введите высоту --->');read(h);
 
  S := (a * h) / 2;
 
  writeln('Площадь треугольника равна', ' ', S);
  writeln('Целая часть - ', Trunc(S));
  writeln('Дробная часть - ', Frac(S));
end.
sohrokova809

73, 8% опрошенных в социальных сетях имеют более друзей. это достаточно много. молодые люди, завязывая дружбу в «виртуальном пространстве», ориентируются в основном, на общность интересов, в таком случае друг является источником какой-либо информации. это, конечно, плюс. однако, в случае виртуальной дружбы возникают следующие проблемы: трудно отследить искренность излагаемой информации, понять истинное отношение виртуального друга к себе, также можно в любой момент прервать общение, нет надобности разрешать конфликты. то есть дружба утрачивает те функции, которые она выполняет в реальном общении, утрачивается и значимость эмоциональной стороны дружбы.

31% молодых людей считают, что общение в интернете решать личные проблемы, а 69% считают, что общение в интернете не этому.

Tarakanova_pavel

Объяснение:

1)У тебя спрашивают b=1? У тебя дано b=3, значит b!=1. Если нет, то переходим к следующим указаниям: с=с-b=4-3=1, b=b+c=3+1(Потому что в предыдущем шаге мы дали новое значение для c, вернее произвели математическую операцию с ним. Возвращаемся(Слева линия) снова к логическому условию. Я честно говоря ХЗ, что они тут имели ввиду, но после того, что я описал c=1,но если мы продолжим проверку b=1, то c начнет принимать отрицательные значения. Цикл вышел, как мне кажется.

Теперь мне лень расписывать - держи фото/скрины

Не знаю, что у тебя за язык программирования, но я сделал тоже самое на Python, вроде результат отличатся не должен.


Здравствуйте решить контрольную по информатике Здравствуйте решить контрольную по информатике
Здравствуйте решить контрольную по информатике Здравствуйте решить контрольную по информатике

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисление площади трехгольника выделить целую часть результата и выделить дробную часть
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rusplatok
keti0290103
Голосова-Лобанов1555
yanva
Наталья
myhauz
Sergei_Olga658
galtig83
cheshirsky-kot
Alekseevich1012
dmitrievanata83538
Irina_Nikolai
yanermarina87
zibuxin6
Natalya1895