makovei78
?>

Составьте программу которая формирует массив из 16 случайных чисел от -20 до 20 и подсчитывает количество отрицацельных элементов

Информатика

Ответы

propercarwashes275
1)
const n=16; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(41)-20;
 write(a[i]:4);
 end;
writeln;
k:=0;
for i:=1 to n do
 if a[i]<0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Массив A:
-14 -7 -20 -3 12 9 -5 -4 7 11 -14 7 6 13 10 12
k = 7

2)
begin
  var a:=ArrRandom(16,-20,20); a.Println;
  var k:=a.Where(x->(x<0)).Count;
  writeln('k = ',k);
end.

Пример:
7 9 -12 12 -7 -14 -16 15 18 -8 -5 -11 1 19 11 5
k = 7
Маркина Ворошилина
// PascalABC.NET 3.0, сборка 1076
type
  Point=record
  x,y:real
  end;
  Line=record
  A,B:Point
  end;
  Triangle=record
  A,B,C:Point;
  sa,sb,sc:real; { длины сторон }
  end;

procedure GetPoint(PointName:char; var M:Point);
begin
  Write('Введите координаты точки ',PointName,'(x,y): ');
  Read(M.x,M.y)
end;

function LineLength(A,B:Point):real;
begin
  LineLength:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;
 
procedure CreateTriangle(var T:Triangle; var l:boolean);
begin
  With T do begin
    GetPoint('A',A);
    GetPoint('B',B);
    GetPoint('C',C);
    sa:=LineLength(B,C);
    sb:=LineLength(A,C);
    sc:=LineLength(A,B);
    l:=(sa+sb>sc) and (sa+sc>sb) and (sb+sc>sa)
  end
end;

function TriangleIsLikes(T1,T2:Triangle):boolean;
var
  k1,k2,k3:real;
begin
  k1:=T1.sa/T2.sa; k2:=T1.sb/T2.sb;
  if k1=k2 then begin
    k3:=T1.sc/T2.sc;
    TriangleIsLikes:=k1=k3
    end
  else
    TriangleIsLikes:=False
end;

var
  T1,T2:Triangle;
  legal:boolean;
begin
  Writeln('*** Первый треугольник ***');
  CreateTriangle(T1,legal);
  if legal then begin
    Writeln('*** Второй треугольник ***');
    CreateTriangle(T2,legal);
    if legal then
      if TriangleIsLikes(T1,T2) then Writeln('Треугольники подобны')
      else Writeln('Треугольники не подобны')
    else Writeln('Треугольник невозможно построить')
    end
  else Writeln('Треугольник невозможно построить')
end.
Galkin Vladimirovich729
Тут особо можно не думать. Замечаем, что в результате надо получить значение А⊕ Ā в восьмиразрядном представлении. Результат такой операции - всегда все единицы во всех разрядах. А разрядов эти по условию 8.

Если формат знаковый, то старший разряд, равный 1 означает, что число отрицательное, а они обычно хранятся в дополнительном коде. Для перевода в основной код инвертируем  все разряды, кроме старшего знакового. Получаем семь нулей. И прибавляем единицу, окончательно получая 10000001, т.е. -1 в двоичной системе. В десятичной системе (как и в любой другой с натуральным основанием, единица - всегда единица.

ответ: -1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая формирует массив из 16 случайных чисел от -20 до 20 и подсчитывает количество отрицацельных элементов
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

TSKaraulova
Хохлов
e3913269
Avshirokova51
mbudilina
boldyrevanastia22
zurabghiendzhoian886
kenni19868
kireevatatiana
Chistov9721209
Картузов-Алексей1252
dakimov
stepa19806966
testovvanya
marinatehnomaster21