Vladimirovna-Ignatenko1890
?>

Уровень c. напишите программу, которая заполняет массив из n = 10 элементов случайными числами в диапазоне [10, 50], выводит его на экран, а затем находит индексы всех элементов, равных введённому числу x. программа должна вывести ответ «не найден», если в массиве таких элементов нет. пример: массив: 12 45 30 18 30 15 30 44 32 17 что ищем: 30 a[3] = 30 a[5] = 30 a[7] = 30

Информатика

Ответы

ella-rudenko
Вот, только выводися только индекс, не нужно же число?
Уровень c. напишите программу, которая заполняет массив из n = 10 элементов случайными числами в диа
sdy19576216
1. а) Петя едет в автобусе, читает книгу и насвистывает.
    б) Петя насвистывает, когда едет в автобусе или читает книгу.
    в) Петя едет в автобусе и читает книгу или насвистывает.
    г) то же, что и а).
   д) Петя едет в автобусе или читает книгу и насвистывает.
2. а) Число 5-простое = 1.    б) Луна-спутник Венеры = 0. 
  в) Число 5-простое и Луна-спутник Венеры = 0.
г) Число 5-простое или Луна-спутник Венеры = 1.
д) Если число 5-простое, то Луна-спутник Венеры = 0.
е) Число 5-простое тогда и только тогда, когда Луна-спутник Венеры = 0.
3. а) 1999<2000 и 1999>2000
б) Петя решил все задания контрольной работы и Петя не решил все задания контрольной работы
в) Неверно, что луна спутник Земли и Неверно, что луна не является спутником Земли
г) Мишень поражена не первым выстрелом и Неверно, что мишень поражена не первым выстрелом.
4. А=1,  В=0,  С=1,  Д=0.
iv1as2

// Массив из "a" заполнил псевдорандомными числами от 0 до 3 для наглядности

using System;

namespace ConsoleApp1

{

   internal class Program

   {

       private static void Main()

       {

           const int numsCount = 24;

           const int resCount = 10;

           double[] nums = new double[numsCount];

           double[] res = new double[resCount];

           var rand = new Random();

           for (int i = 0; i < numsCount; i++)

           {

               nums[i] = rand.Next(0, 4);

               Console.WriteLine($"a[{i}] = {nums[i]}");

           }

           Console.WriteLine();

           for (int i = 1; i <= resCount; i++)

           {

               double sum = 0;

               for (int j = 0; j < numsCount; j++)

                   sum += Math.Pow(nums[j], i);

               res[i - 1] = sum;

               Console.WriteLine($"b[{i - 1}] = {sum}");

           }

           Console.ReadLine();

       }

   }

}


Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови
Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Уровень c. напишите программу, которая заполняет массив из n = 10 элементов случайными числами в диапазоне [10, 50], выводит его на экран, а затем находит индексы всех элементов, равных введённому числу x. программа должна вывести ответ «не найден», если в массиве таких элементов нет. пример: массив: 12 45 30 18 30 15 30 44 32 17 что ищем: 30 a[3] = 30 a[5] = 30 a[7] = 30
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rusart3
Федоровна-Васильева
xachen
tteplovoz3789
julkamysh9
nadezhdasvirina
kmb1960679
Иванович621
Nikishina
mnkrasnova
mzubenko6
baxirchik
rudakovam198
demon8608
Stenenko