Sergei1198
?>

Написать программу на я/п паскаль : среднее арифметическое пяти произвольных чисел

Информатика

Ответы

Татьяна_Вологжин
Var a,b,c,d,e,sum:integer;
begin
b:=random(-10000;10000);
a:=random(-10000;10000);
c:=random(-10000;10000);
d:=random(-10000;10000);
e:=random(-10000;10000);
sum:=a+b+c+d+e;
write(sum/5);
end.
Gavrilova2527
Var a, b, c, d, e: real;
begin
write('Введите 5 чисел через пробел: '); readln(a, b, c, d, e);
writeln('Среднее арифметическое = ', (a+b+c+d+e)/5);
end.
Shelchkowa453

1. Создайте личную папку, куда вы будете сохранять все файлы своего сайта.

2. Запустите программу Блокнот (Notepad).

3. Наберите в окне программы простейший файл HTML.

<HTML>

<HEAD>

<TITLE>Учебный файл HTML</TITLE>

</HEAD>

<BODY>

Расписание занятий на вторник

</BODY>

</HTML>

4. Сохраните файл под именем RASP.HTML (обязательно укажите тип файла HTML при сохранении) в личной папке.

5. Для просмотра Web-страницы используйте любую программу браузера (Internet Explorer, Opera, Mozilla Firefox или другую). Для этого, не покидая программу Блокнот (сверните окно на панель задач), откройте личную папку и двойным кликом по файлу RASP.HTML откройте окно браузера.

Рисунок 10 – Результат работы

На экране вы увидите результат работы, изображенный на рисунке 10.

Объяснение:

artemka56rus
Написано и протестировано в PascalABC.NET (версия 2.2, сборка 842)
const
 s='велосипедист';
var
 t:='кытунак';
 p:string;
begin
  // 1
  Writeln(LeftStr(s,9),', ',
    s[12]+s[2]+s[5]+s[12]+s[4],', ',
    s[4]+Copy(s,3,2)+s[1]+s[4]);
  // 2
  Writeln('Позиция буквы "д" в слове "'+s+'" равна ',s.IndexOf('д')+1);
  // 3
  Write('Было: ',t,', стало: ');
  t[2]:='о'; t[4]:='е'; t:=t.Replace('а','о');
  Writeln(t);
  // 4
  Write('Коды символов слова ',t,': ');
  foreach c:char in t do Write(Ord(c),' ');
  Writeln;
  // 5
  Write('В слове ',t,' количество букв ');
  if Odd(t.Length) then Writeln('нечетное') else Writeln('четное')
end.

Результат выполнения программы:
велосипед, тесто, олово
Позиция буквы "д" в слове "велосипедист" равна 9
Было: кытунак, стало: котенок
Коды символов слова котенок: 234 238 242 229 237 238 234
В слове котенок количество букв нечетное

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на я/п паскаль : среднее арифметическое пяти произвольных чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

svetlanam81
mrilyushchenko6
Viktorovna1012
Polina780
zmlavra
igraparkGP51
ПогальниковАлёна589
taanaami75
stratocasterr34
egcuzn86
osandulyak
Ивлев1508
Ямпольский
muravlev2702
westgti77105
▲