gusinica23
?>

1. определите, что делает следующая программа и какой результат она выдаст на заданном массиве (1, 4, 0, -1, 6 var a: array[1..5] of integer; i, b: integer; begin b: =a[ 1 ]; for i: =2 to n do if a[i]> b then b: =a[i]; writeln(b) end. 2. чему будет равно значение k после выполнения программы? var m, k: integer; begin m: =0; k: =1; while (m< 5) do m: =m+1; k: =k+m; writeln(k); end. варианты ответов: а) 2; б) 3; в) 4; г) 5. заранее !

Информатика

Ответы

Belokonev286
1. Результат программы  - 4
2. После выполнения программы k будет равен 5
andyrvo
Это задача на вычисление суммы после уплаты налога.
Если s0  - исходная сумма, а р - процент налога, то ищется s=s0-s0*p/100.
Окончательная формула: s=s0(1-p/100)

const
  p=13;  { налог в процентах }
var
  s0,s:real;
begin
  Write('Введите сумму '); Read(s0);
  s:=s0*(1-p/100);
  { а теперь округлим сумму до копеек, т.е. до 0.01 }
  s:=Int(100*(s+0.005))/100;
  Writeln('Сумма после вычета налога ',p,'% составит ',s:0:2)
end.

Тестовое решение:
Введите сумму 2000
Сумма после вычета налога 13% составит 1740.00

Замечание. При целочисленной зарплате и целочисленном проценте налога оператор s:=Int(100*(s+0.005))/100; не нужен, поскольку в дробной части всегда будет не больше двух знаков. Но, поскольку о сумме зарплаты ничего не говорится, а дано только конкретное значение, которое понято как тестовый пример, было предложено решение с округлением.
алексей-Ветошкин

program raf105;

const

 n = 35;

var

 a: array[1..30] of integer;

 b: array[1..40] of integer;

 c: array[1..n] of integer;

 i : integer;

begin

 writeln('Заполните массив A');

 for i:=1 to 30 do

   readln(a[i]);

   

 writeln('Заполните массив B');

 for i:=1 to 40 do

   readln(b[i]);

   

 writeln('Заполните массив C');

 for i:=1 to n do

   readln(c[i]);

   

 for i:=1 to 40 do

 begin

   if (a[i] < 0) or (b[i] < 0) then

     begin

       writeln('Нет');

       break

     end;

   if c[i] < 0 then

     begin

       writeln('Да');

       break

     end;

 end;

end.

PascalABC

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. определите, что делает следующая программа и какой результат она выдаст на заданном массиве (1, 4, 0, -1, 6 var a: array[1..5] of integer; i, b: integer; begin b: =a[ 1 ]; for i: =2 to n do if a[i]> b then b: =a[i]; writeln(b) end. 2. чему будет равно значение k после выполнения программы? var m, k: integer; begin m: =0; k: =1; while (m< 5) do m: =m+1; k: =k+m; writeln(k); end. варианты ответов: а) 2; б) 3; в) 4; г) 5. заранее !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

komolovda
НатальяРуктешель472
alexsan-0837
Ахади
ирина_Андреевич1634
Nugamanova-Tatyana840
Елена-Семенова
missmorozova2
mar77873
Reutskii-Kirilovskii1625
moskvabelarus
sport2293032
molchanovaelena284
makitra08
ivanov568