sales5947
?>

Паскаль даны значения двух моментов времени: часы, потом минуты и секунды. известно, что второй момент времени наступил не раньше первого и разница между ними менее суток. определите, сколько секунд между двумя моментами времени. в первой строке входных данных находятся три целых числа — часы, минуты и секунды первого момента времени. во второй строке три числа, характеризующие второй момент времени. число часов лежит в диапазоне от 0 до 23, число минут и секунд — от 0 до 59. выведите число секунд между двумя моментами времени. пример входных данных 1 1 1 2 2 2 1 2 30 1 3 20 пример выходных данных 3661 50

Информатика

Ответы

Максим

xD

uses crt;

var

dt,t1,t2:LongInt;

function GetTime:LongInt;

var

substr,str:string;

ERR,step,spacepos,code,num:Integer;

t:longint;

begin

ERR:=0;

repeat

t:=0;

step:=1;

if ERR<>0 then writeln('Nepravilnie dannie, povtorite vvod:');

ERR:=0;

readln(str);

str:=str+' ';

repeat

spacepos:=pos(' ',str);

if (spacepos<>0) then

begin

substr:=copy(str,1,spacepos-1);

delete(str,1,spacepos);

val(substr,num,code);

if code=0 then

begin

if (step=1) then begin if (num>=0) and (num<=23) then t:=t+num*60*60 else ERR:=3; end;

if (step=2) then begin if (num>=0) and (num<=59) then t:=t+num*60 else ERR:=3;end;

if (step=3) then begin if (num>=0) and (num<=59) then t:=t+num else ERR:=3;end;

inc(step);

end

else ERR:=2;

end else ERR:=1;

until ((step=4) or (err<>0));

until err=0;

GetTime:=t;

end;

begin

writeln('pervoe vremy:');

t1:=GetTime;

writeln('vtoroe vremy:');

t2:=GetTime;

if t2>=t1 then dt:=t2-t1 else dt:=t2-t1+24*60*60;

writeln('raznica v sekundah: ');

writeln(dt);

end.

Малыхин Валерьевна621
Если не ошибаюсь ответ г Автоматическое форматирование — это средство Word для анализа частей документа и распознавания отдельных элементов, таких как основной текст, заголовки, маркированные списки и др. Word может применить соответствующие стили к различным элементам текста для создания отформатированного документа. (О стилях вы узнали в уроках 12 и 13). Вы можете принять или отвергнуть автоматически предложенный формат, частично или в целом, и позже внести необходимые изменения в документ. Кроме применения стилей, автоматическое форматирование удаляет лишние пробелы между абзацами, автоматически форматирует адреса Internet, ллектронной почты и сетевые адреса как гиперссылки, выделяет полужирным начертанием или подчеркиванием текст, ограниченный звездочками (*) или символами подчеркивания (_), заменяет два дефиса (--) одним тирс II Т. Д.
basil69
var                                      
i,z,y,x: integer;                 // объявление переменных
begin                              // начало программы
writeln('Введите числа: '); // Вывод сообщения
readln(x,y);                      // Ввод чисел х и у с клавиатуры
while i <> y do                 // Повторять цикл пока i не будет равно y
 begin                             // Вход в цикл
 z:=z+x;                          // z = z + x  (при первом шаге получается 0 = 0 + х) 
 i:=i+1;                            // Увеличиваем счетчик цикла на 1 
 end;                               // Выход из цикла
write(z);                           // Вывод z (произведение х и у)
end.                                // Конец программы 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль даны значения двух моментов времени: часы, потом минуты и секунды. известно, что второй момент времени наступил не раньше первого и разница между ними менее суток. определите, сколько секунд между двумя моментами времени. в первой строке входных данных находятся три целых числа — часы, минуты и секунды первого момента времени. во второй строке три числа, характеризующие второй момент времени. число часов лежит в диапазоне от 0 до 23, число минут и секунд — от 0 до 59. выведите число секунд между двумя моментами времени. пример входных данных 1 1 1 2 2 2 1 2 30 1 3 20 пример выходных данных 3661 50
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ibombenkova
kgrechin
aetolstih
lepekhov4011
paninsv
alfakurs
Anastasiya
Захаров-Иванович
leeteukism
Alekseevich1012
verav75
Svetlana1884
borisovaks496
avdeevana
ashantik