delena6467
?>

Написать программу по информатике на паскале. создать с клавиатуры массив из трех чисел-первое число от 1 до 25, второе от 26 до 50, третье от 51 до 100. создать второй массив случайным образом по таким же правилам. сравнить эти числа и написать сколько совпало

Информатика

Ответы

snabomp
Type mas=array[1..3] of integer;
var a,b:mas;
i,k:integer;
procedure proc(var x:mas);
var i:integer;
begin
x[1]:=random(25)+1;
x[2]:=random(25)+26;
x[3]:=random(50)+51;
for i:=1 to 3 do write(x[i],' ');
writeln;
end;
begin
randomize;
writeln('1-й массив:');
proc(a);
writeln('2-й массив:');
proc(b);
k:=0;
for i:=1 to 3 do
 if a[i]=b[i] then k:=k+1;
writeln('Число совпавших элементов = ',k);
end.

Пример:
1-й массив:
6 29 58
2-й массив:
21 29 63
Число совпавших элементов = 1
oyudina
Var a,b:array[1..3] of integer;
begin
a[1]:=Random(26); b[1]:=Random(26);
a[2]:=Random(26)+25; b[2]:=Random(26)+25;
a[3]:=Random(51)+50; b[3]:=Random(51)+50;
writeln(a[1],' ',a[2],' ',a[3]);
writeln(b[1],' ',b[2],' ',b[3]);
if (a[1]=b[1]) and (a[2]=b[2]) and (a[3]=b[3])
then writeln('Совпало 3')
else
if ((a[1]=b[1]) and (a[2]=b[2])) or ((a[2]=b[2]) and (a[3]=b[3])) or ((a[1]=b[1]) and (a[3]=b[3]))
then writeln('Совпало 2')
else
if (a[1]=b[1]) or (a[2]=b[2]) or (a[3]=b[3])
then writeln('Совпало 1')
else writeln('Совпадений нет');
end.

P.S Писал не на компьютере, возможны ошибки, проверьте и в случае если обнаружатся ошибки, напишите мне
scraer198258
Книгопечатание в 15 веке уже распространилось по всей Европе известно до 1000 имён печатников того времени, число же изданий, вероятно, доходит до 30000 (так называемые инкунабулы); 6/7 этого количества составляют сочинения религиозные и схоластические, остальные — научные и древняя и новая литература. Формат — in folio, разделённый на два столбца, или in quarto. Шрифт остался прежний — письменный готический прямоугольный. Только в Италии печатники начали применять употреблявшийся там ещё с XIV века круглый шрифт, так называемый римский, который впоследствии и вытеснил готический.
valerii-borisovich550
1.

var
i: integer;
A: array [1..20] of integer;

begin
randomize;
writeln('Массив: ');
for i:=1 to 20 do A[i]:=random(21)-10;
 for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Каждый пятый эелемент массива: ');
 for i:=1 to 20 do if i mod 5 = 0 then write(A[i]:5);
end.

2.
var
x,i: integer;
A: array [1..20] of integer;

begin
randomize;
writeln('Массив: ');
 for i:=1 to 20 do A[i]:=random(11);for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Натуральные числа в диапазоне [5..10]: ');
 for i:=5 to 10 do write(A[i]:5);
writeln;
x:=1;
writeln('Их произведение: ');
 for i:=5 to 10 do x:=A[i]*x;
write(x:5); 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу по информатике на паскале. создать с клавиатуры массив из трех чисел-первое число от 1 до 25, второе от 26 до 50, третье от 51 до 100. создать второй массив случайным образом по таким же правилам. сравнить эти числа и написать сколько совпало
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Leobed917670
a1rwalk3r
Nataliyaof
mishanay301csfp
Pautova1119
kyrtlab39
rstas
Александрович175
proh-dorohova5244
lilit-yan
jim2k
annakuznetsova841
turoverova5
sigidinv