Shirochkingames
?>

Python. напишите программу, которая переставляет соседние элементы массива: 1-й со 2-м, 3-й с 4-м и т.д. нумерация элементов начинается с единицы. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

Информатика

Ответы

pechyclava
N = int(input())
a = input().split()
for i in range(0, n - n % 2, 2):
    a[i], a[i + 1] = a[i + 1], a[i]
print(' '.join(a))
osnickyi

1

//Вводим a,b,c

Console.WriteLine(hello);

if(a == b || a==c || b==c){

Console.WriteLine("Треугольник равнобедренный");

}else{

Console.WriteLine("Треугольник НЕ равнобедренный");

}

2

int x1,x2,x3,x4;

int x;

//Вводим число x

   x1 = (x - (x % 1000)) / 1000;

   x2 = ((x - (x % 100)) - (x - (x % 1000))) / 100;

   x3 = ((x - (x % 10)) - (x - (x % 100))) / 10;

   x4 = x % 10;

if((x1 == 6) || (x1 == 9) || (x2 == 6) || (x2 == 9) || (x3 == 6) || (x3 == 9) || (x4 == 6) || (x4 == 9)){

Console.WriteLine("Входит");

}else{

Console.WriteLine("не входит");

}

3

float x,y,z;

// Вводим x,y,z

if(x >= 0,5 && x<=5,1) Console.WriteLine(x, " Входит");

if(y >= 0,5 && y<=5,1) Console.WriteLine(y, " Входит");

if(z >= 0,5 && z<=5,1) Console.WriteLine(z, " Входит");

4 задания к сожалению не понял

борисовна Елена78
Задание №1

var r:integer; 
begin 
writeln('Введите радиус'); 
read(r); 
writeln('Длина окружности = ',2*pi*r); 
writeln('Площадь круга = ',pi*sqr(r)); 
end.

Задание №2

var a,d,n:integer; 
begin 
writeln('Введите первый член, знаменатель, число членов'); 
read(a,d,n); 
writeln('Cумма членов арифметической прогресси = ', 0.5*n*(2*a+(n-1)*d)); 
end. 

Задание №3

var m,n:integer; 
begin 
writeln('Введите m и n'); 
read(m,n); 
if m=n then begin 
m:=0; 
n:=0; 
end; 
if (m>n) then n:=m 
else if n>m then m:=n; 
end.

Задание №4

var a,b,c:integer; 
begin 
writeln('Введите стороны a,b,c'); 
read(a,b,c); 
if (a=b) or (b=c) or (c=a) then writeln('Треугольник равнобедренный') 
else writeln('Треугольник неравнобедренный'); 
end.

Задание №5

var a,b,c:integer; 
begin 
a:=0; 
c:=0; 
repeat 
writeln('Введите число'); 
read(b); 
if b<0 then a:=a+1; 
c:=c+1; 
until c=3; 
writeln('Количество отрицательных = ',a); 
end.

Задание №6

var a,c:integer; 
b:real; 
begin 
writeln('Введите количество часов'); 
read(a); 
c:=a div 3; 
b:=power(2, c); 
writeln(b); 
end.

Задание №7

const 
n=10; 
var a:array [1..10] of integer; 
i,k,s:integer; 
begin 
writeln('Введите k'); 
read(k); 
writeln('Введите элементы массива'); 
for i:=1 to n do begin 
read(a[i]); 
if a[i] mod k =0 then s:=s+a[i]; 
end; 
writeln(s); 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python. напишите программу, которая переставляет соседние элементы массива: 1-й со 2-м, 3-й с 4-м и т.д. нумерация элементов начинается с единицы. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vladimirdoguzov
Nikishina
buleckovd8724
mstrshulz
orantus3
dshi67orbru
rayman777
TrubnikovKlimenok926
Константиновна
Максим Павел
skorykin123371
yurogov61
Светлана-Тигран
EkaterinaSEMENOV702
Yanusik24