dshi67orbru
?>

На языке программирования С++ составить программу для нахождения количества отрицательных чисел на промежутке от А до В.

Информатика

Ответы

ikhilovb76

#include <iostream>

using namespace std;

int main() {

cout << "A: ";

int a = 0;

cin >> a;

cout << "B: ";

int b = 0;

cin >> b;

if(a>b) {

 cout << "error. a>b";

 return 0;

}  

int counter = 0;

for(int i = a; i<=b; ++i) {

 if(i<0) {

  ++counter;

 }

}  

cout << "otr chisel: " << counter;

}

okykovtun31
Для решения определим 
1. Время передачи по высокоскоростному каналу
2. Время передачи по низкоскоростному каналу
3. Время для получения первых 1024 Кб
4. Всё сложим.

2^20 бит/с = 2^20 / 8 / 1024 Кбайт/с = 2^20 / 2^3 / 2^10 = 2^7 Кбайт/с
2^13 бит/с = 2^13 / 8 / 1024 Кбайт/с = 2^13 / 2^3 / 2^10 = 2^0 = 1 Кбайт/с
10 Мб равно 10*1024 Кбайт = 10*2^10 Кбайт.

По высокоскоростному каналу файл будет передаваться
(10*2^10) / 2^7 = 10*2^3 = 80 секунд

По низкоскоростному каналу файл будет передаваться
(10*2^10) / 1 = 10*2^10 = 10240 секунд.

Первые 1024 Кбайт будут передаваться
2^10 / 2^7 = 8 секунд

Общее время 80+10240+8 = 10328 секунд.
ccc712835
Ввод графической информации может быть осуществлён с различных устройств: клавиатуры, мыши, сканера или графического планшета. Каждое из них имеет те или иные достоинства, но основной характеристикой является удобство использования. Клавиатура плохо подходит для построения изображений, так как она изначально предназначена для набора символьной, а не графической информации. Однако применение клавиатуры для ввода графической информации имеет определённые преимущества. С клавиш можно перемещать курсор каждый раз на одну позицию. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На языке программирования С++ составить программу для нахождения количества отрицательных чисел на промежутке от А до В.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kamimoza
shalashcoffee
lulu777
Анатольевич1707
arch5050
xalina85
skvorec3424
Vladimirovna Viktorovna
VASILEVNA
petrowanastya202081
Leon-12
Wlad967857
fellybrossme
gardenkafe
Dushko