galereyaas1568
?>

Составьте программу, которая определяет какое из трех введенных с клавиатуры чисел является средним.если среди чисел есть равные, то вывести сообщение"ошибка"

Информатика

Ответы

ars-trushakova
Var a,b,c: integer;
begin
  write('числа: '); readln(a,b,c);
  if a>b then swap(b,c);
  if c<a then swap(a,c);
  if b>c then swap(b,c);
  if (a=b) or (b=c) then writeln('ошибка')
  else writeln('среднее: ',b);
end.

числа: 9 17 8
среднее: 9
shchepinasm
Замечание. Так как количество вводимых чисел заранее не известно, то откроем бесконечный цикл со всегда верным условием True, но как только будет введено число 0, остановим цикл командой break.

Программа:

program z;
var k,s,x:integer;
begin
k:=0;              {начальное значение количества двузначных чисел}
s:=0;              {начальное значение суммы двузначных чисел}
while True do  {открываем бесконечный цикл}
begin
readln(x);        {вводим число х}
if x=0 then break;  {если введенное число равно 0, то остановить цикл}
if (x>9)and(x<100) then  {если число двузначное, т.е. от 10 до 99} 
    begin 
    k:=k+1;         {количество увеличиваем на 1}
    s:=s+x;         {увеличиваем предыдущее значение суммы на число х}
    end;
end;
if k=0 then writeln('NO')  {если двузначных чисел не было, то вывод NO}
   else writeln(s/k);          {иначе вывод ср.арифметического}
end.
siren89
PYfy9pX4YibdfKzE8dnbSXaP3D5sbZenWQXx+TzottBxmrnKP4dS39zDFCHeytaxQuaxO6+SihcUhSqF6PmmxN3GxGIIAPLiSxjqjTtSHbvo7htEBwkC9DrKA9nK9xIOxPRcjpd6DAdMG0SkqPbK1+57wXgl2KsD43bDyI91iNHZGVEFuJjW2WjoZmDZOb/rVd7R9AqyWfNwqgLu5n0s8oZKpT55zvtPlOdDo6CM93h3C9G55Qj17fBXO/NNywpSzMGUqCxZha8Dm9QprL4Amawdo2pnCyu31Kn+Zny692acWR8k+IjeIoeL9HS7GGpxomAYoUcl2QOl2meKVWiovxtHmLKNooQK1Hc8yqvu293YHqgzQp3rHNgJxPJfiQnUmlYXGvOGZLk6vEUXIiesvdftDsCS/8Ae6YiLr8HWExGez9YXrworoX46BqS86+EFy3m8zwgu1fA9z61qLUP90KYw8KxlJJDWAThAVGrADHEsoHJ35+216/jwx5ruS3xgPOL83Vy5P1bL884jUiefVsuhprgR7C75lvy2ZCUYolQ=

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая определяет какое из трех введенных с клавиатуры чисел является средним.если среди чисел есть равные, то вывести сообщение"ошибка"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Arsen0708
Galkin Vladimirovich729
verynzik66525
Мария-Кострыгина175
Диана-Николаевна377
deshkina82
snezhanaklimenkova
Лоскутова
lshimina65
es196
vasilevich-F
kokukhin
helenya
Olgax732
Devaunka40