Решение ниже. Программа на языке с++.
Объяснение:
#include <stdio.h>
#include <iostream>
#include <locale.h>
using namespace std;
int main()
{
setlocale(LC_ALL, "Russian");
int x, i;
cout << "Введите размерность массива: ";
cin >> x;
int* Arr = new int[x];
cout << "Введите " << x << " элементов массива через пробел: " << endl;
for (i = 0; i < x; i++)
{
cin >> Arr[i];
}
cout << endl << "ответ: ";
for (i = 0; i < x; i++)
{
if (Arr[i] % 2 == 0)
{
cout << Arr[i] << " ";
}
}
for (i = 0; i < x; i++)
{
if (Arr[i] % 2 != 0)
{
cout << Arr[i] << " ";
}
}
return 0;
}
первый цикл for заполняет массив array, случайными числами из указанного диапазона, в цикле while происходит поиск пары чисел по условию начиная с 3го элемента. Если находят выводят, что такая пара есть, в противном случае что такой пары нет.
ЛИБО
Вводтся число n, дальше будет использоваться для поиска, дальше как и в программе а, заполняем массив случайными числами в цикле for, в repeat, мы движемся по массив, пока не встретим наше значение n, если встретили, выводим: такое число есть в массиве, в противном случае, такого числа нет.В repeat until реализован линейный алгоритм поиска.
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Пользователь вводит число с клавиатуры. составьте программу, которая, в случае, если данное число положительное прибавляет к нему 3, а если отрицательное – вычитает 3. !