nst-33764
?>

Решать через паскаль! даны числа n и m. создайте массив a[n][m] и заполните его змейкой (см. пример входные данные программа получает на вход два числа n и m. выходные данные программа должна вывести полученный массив, отводя на вывод каждого числа ровно 3 символа. примеры входные данные 4 10 выходные данные 0 1 2 3 4 5 6 7 8 9 19 18 17 16 15 14 13 12 11 10 20 21 22 23 24 25 26 27 28 29 39 38 37 36 35 34 33 32 31 30 я написала программу всё правильно , но она начинается не с нуля исправьте ошибку: var a: array[1..100, 1..100] of integer; i, j, n, m: integer; begin readln(n, m); for i: =1 to n do begin for j: =1 to m do begin if i mod 2=1 then a[i, j]: =(i-1)*m+j else a[i, j]: =i*m-j+1; write(a[i, j]: 3); end; writeln; end; end. 4 10 1 2 3 4 5 6 7 8 9 10 20 19 18 17 16 15 14 13 12 11 21 22 23 24 25 26 27 28 29 30 40 39 38 37 36 35 34 33 32 31

Информатика

Ответы

martabunova
Попробуй начать цикл с i не с 1, а с 0
poiskmarina
Const
  N = 30;

var
  a: array [1..N] of integer;
  i, nel, x: integer;

begin
  writeln('Введите элементы массива');
  for i := 1 to N do read(a[i]);
  writeln('введите Х');
  readln(x);
  nel := 0;  // номер найденного элемента
  i := 1;
  while (i <= n) and (nel = 0) do
  begin
    if a[i] = x then nel := i;
    i := i + 1
  end;
  if nel > 0 then
    writeln('Номер элемента ', nel)
  else
    writeln('Не найден элемент, удовлетворяющий условию')
end.

Тестовый пример:

Введите элементы массива
1 3 6 8 4 9 14 -4 7 45 4 8 0 23 63 253 23 453 54 20 54 12 -56 3 0 -34 28 27 90 23
введите Х
0
Номер элемента 13
saint158

Объяснение:

// Example program

#include <iostream>

#include <string>

int main()

{

   int k[30];

   for(int i = 0; i < 30; i ++) //заполняем случайными числами

       k[i] = rand();

   int min_sum = 999999999;

   int num1, num2;

   for(int i = 0; i < (30 - 1); i ++) //цикл поиска, i меняется от начала

                                      //до предпоследнего элемента, чтобы не выйти

                                      //за пределы при обращении к i + 1 элементу

   {

       int sum = k[i] + k[i+1];//очередная сумма

       if(sum < min_sum) //сравниваем ее с текущим минимумом

       {//если она меньше, то

           min_sum = sum;//обновляем текущую сумму

           num1 = i; num2 = i + 1;//обновляем номер

       }

   }

   //на выходе из цикла в min_sum и num1 и num2 имеем самые минимальные номера

   std::cout << "min_sum = " << min_sum << " nomer1 = " << num1 <<" nomer2 = " << num2;

}


решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать прои
решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать прои

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решать через паскаль! даны числа n и m. создайте массив a[n][m] и заполните его змейкой (см. пример входные данные программа получает на вход два числа n и m. выходные данные программа должна вывести полученный массив, отводя на вывод каждого числа ровно 3 символа. примеры входные данные 4 10 выходные данные 0 1 2 3 4 5 6 7 8 9 19 18 17 16 15 14 13 12 11 10 20 21 22 23 24 25 26 27 28 29 39 38 37 36 35 34 33 32 31 30 я написала программу всё правильно , но она начинается не с нуля исправьте ошибку: var a: array[1..100, 1..100] of integer; i, j, n, m: integer; begin readln(n, m); for i: =1 to n do begin for j: =1 to m do begin if i mod 2=1 then a[i, j]: =(i-1)*m+j else a[i, j]: =i*m-j+1; write(a[i, j]: 3); end; writeln; end; end. 4 10 1 2 3 4 5 6 7 8 9 10 20 19 18 17 16 15 14 13 12 11 21 22 23 24 25 26 27 28 29 30 40 39 38 37 36 35 34 33 32 31
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Silaev988
yuda12
Ubuleeva826
Герасименко
Дементьева-Артем1315
steam22-9940
slspam
rukodelnizza1
Ladyby6224
ecogoi
modno-trikotazh
topshopnails
warlordkolomna
Инна_Nina1182
kulikovtsud