Абдулганиева Сергей
?>

Написать программу, выводящую на экран ответ, содержится ли цифра 5 в трехзначном числе

Информатика

Ответы

oooviktoria17
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadInteger();
write(a.ToString().Contains('5'));
end.
monolit-kolomna
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк (столбцов) в массиве:');
  Writeln('*** Исходный массив [',n,',',n,'] ***');
  var a:=MatrRandom(n,n,-10,10);
  a.Println(4); Writeln(5*a.ColCount*'-');
  var k,l:integer;
  Write('Введите L,K: '); Read(l,k);
  var lim:=a[l-1,k-1];
  var s:=a.Rows.SelectMany(x->x).Where(x->x<lim).Sum;
  Writeln('Искомая сумма равна ',s)
end.

Пример
Количество строк (столбцов) в массиве: 6
*** Исходный массив [6,6] ***
  -4  -8  -7  -3  -6  -4
   2  -9   1   9  -6   6
  -9  -2  -8  -3  -1  -4
  -1  -9  -3  -7   3  -3
   5   9  -6   8  -1 -10
  -1  -1  -5  -8  -9   4

Введите L,K: 2 3
Искомая сумма равна -138
ldstroy

#include<iostream>

#include<windows.h>  

using namespace std;

 

struct Sponsor

{

char name[32];

char surname[32];

double sum;

};

 

Sponsor* AddStruct(Sponsor* Obj, const int amount);

void setData(Sponsor* Obj, const int amount);

void showData(const Sponsor* Obj, const int amount);

 

int main()

{

setlocale(LC_ALL, "rus");

 

Sponsor* OurSponsors = 0;

int sponsorAmount = 0;

int YesOrNot = 0; //  продолжить или остановить ввод данных

 

do

{

OurSponsors = AddStruct(OurSponsors, sponsorAmount);

setData(OurSponsors, sponsorAmount);

 

sponsorAmount++;

 

cout << "Продолжить ввод данных (1 - да, 0 - нет): ";

cin >> YesOrNot;

cin.get();

} while (YesOrNot != 0);

 

showData(OurSponsors, sponsorAmount);

 

delete[] OurSponsors;

return 0;

}

 

Sponsor* AddStruct(Sponsor* Obj, const int amount)

{

if (amount == 0)

{  

Obj = new Sponsor[amount + 1]; // выделение памяти для первой структуры

}

else

{

Sponsor* tempObj = new Sponsor[amount + 1];

 

for (int i = 0; i < amount; i++)

{

tempObj[i] = Obj[i]; // копируем во временный объект

}

delete [] Obj;

 

Obj = tempObj;  

}  

return Obj;

}

//

void setData(Sponsor* Obj, const int amount)

{

cout << "Фамилия: ";

cin.getline(Obj[amount].surname, 32);

cout << "Имя: ";

cin.getline(Obj[amount].name, 32);

cout << "Сумма пожертвования: ";

cin >> Obj[amount].sum;

cin.get();  

cout << endl;  

}

//

void showData(const Sponsor* Obj, const int amount)

{

system("cls");

cout << "№  " << "Фамилия\t" << "Имя\t" << "Сумма\t" << endl;

cout << "" << endl;

for (int i = 0; i < amount; i++)

{  

cout << i + 1 << "  " << Obj[i].surname << '\t' << Obj[i].name << '\t' << Obj[i].sum << endl;

}

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, выводящую на экран ответ, содержится ли цифра 5 в трехзначном числе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mnatsovna
tashovairina
ganorussia
IrinaSolodukhina1495
bei07
Борисовна_Кашутина
maxim-xx38
Aleksandrovna Kolesnik1764
uuks2012
olga0909196323
bagrjashv41
eronch
AlekseiMardanova
aedunova3
sv-opt0076