aguliaeva
?>

Паскаль. нужно составить программу для нахождения цифр трехзначного числа через запятую. например, при вводе мы пишем 123, а на выходе должно получиться 1, 2, 3

Информатика

Ответы

naratnikova
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  ReadInteger.ToString.ToCharArray.Println(',')
end.

Пример
123
1,2,3

Замечание: число не обязано быть трехзначным.
karnakova-a

1)

var a,b,x,y:longint;

begin

write("Vvedite nachalo i konec otrezka: ");

read(a,b);

write("Vvedite x: ");

read(x);

y:=sqr(x)*x;

if (y>a)and(y<b) then write("Na dannom otrezke znachenie funkcii ravno ",y) else write("Na dannom otrezke net reshenii");

readln

end.

2)

var c,i:byte;

begin

for i:=49 to 215 do

if (i mod 4=0) then c:=c+1;

write("Kolichestvo chisel, kratnyh 4 na zadannom promezhutke ravno ",c);

readln

end.

3)

var i:integer;

p:longint;

for i:=1000 to 9999 do

if (i mod 10=3) then p:=p*i;

write("Proizvedenie chetyrehznachnyh chisel, okanchivaushihsya na 3 ravno ",p);

readln

end.

4)

var i:byte;

c:integer;

begin

for i:=221 to 778 do

if ((i mod 10)=(i div 100)) then c:=c+1;

write("Kolichestvo chisel ravno ",c);

readln

end.

5)

var i:longint;

c:integer;

begin

for i:=10000 to 99999 do

if ((i mod 10)=(i div 10000))and(((i mod 100)div 10)=((i div 1000)mod 10)) then c:=c+1;

write("Kolichestvo chisel ravno ",c);

readln

end.

misstimarina2016
1) F=Av(¬A&B)
По закону дистрибутивности раскроем скобки
(Av¬A)&(AvB)
Av¬A = 1, значит остаётся AvB

2) F =A&(¬AvB)
По тому же закону раскрываем скобки
(A&¬A)v(A&B)
A&¬A = 0, значит остаётся A&B

3. (AvB)&(¬BvA)&(¬CvB)
По закону склеивания (AvB)&(¬BvA) = A , получается, что выражение принимает вид
A&(¬CvB)
Можно раскрыть скобки, получим
A&¬C v A&B

4) F =(1v(AvB))v((AC)&1) 
Скобка (1v(AvB)) = 1, так как 1 v ЧТОУГОДНО = 1
Получаем выражение
1v((AC)&1) = 1, так как 1 v ЧТОУГОДНО = 1
ответ 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. нужно составить программу для нахождения цифр трехзначного числа через запятую. например, при вводе мы пишем 123, а на выходе должно получиться 1, 2, 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

YuREVICh646
Seid-ZadeNadezhda1769
Kochinev4
Tochkamail370
KseniGum9
Solovetzmila
maryariazantseva
Dmitrievna-Dmitrii980
titovass9
Artur-62838
vakhitov100961
Сергей_Комарова899
petrova-kate3
Tatyana1374
alexeytikhonov
▲