Поделитесь своими знаниями, ответьте на вопрос:
Дано целое число x и натуральное n. составьте алгоритм вычисления xn. проверьте алгоритм трассировкой. напишите программу на паскале. через while do
x, n, ans:integer;
begin
Readln(x, n);
while (n > 0) do
begin
ans := ans + x;
n:= n - 1;
end;
Writeln(ans);
end.