zrs-546
?>

Напишите программу на паскале для вычисления произведение отрицательных. количество введенных чисел неизвестно, 0 – признак окончания ввода чисел.

Информатика

Ответы

drozd2008
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
write(ReadSeqIntegerWhile(x->x<>0).Where(x->x<0).Aggregate(BigInteger(1),(x,y)->(x*y)));
end.
mbudilina

использовать Рисователь

алг

нач

новый лист(600, 400, белый)

в точку (250,350)

линия в точку (300,75)

линия в точку (350,350)

линия в точку (250,350)

кисть(красный)

окружность(300, 75, 20)

залить(300,250)

в точку (200,350)

линия в точку (100,100)

линия в точку (265,265)

линия в точку (250,350)

линия в точку (200,350)

кисть(синий)

окружность(100, 100, 20)

залить(200,300)

в точку (400,350)

линия в точку (500,100)

линия в точку (335,265)

линия в точку (350,350)

линия в точку (400,350)

кисть(зеленый)

окружность(500, 100, 20)

залить(400,300)

кон

Объяснение:

Смотри картинку


Сделайте вот такую корону в кумире
ivan-chay19
#include
необходим для подключения заголовочных файлов из стандартной библиотеки C/C++ (в этом случае название заголовочного файла указывается в угловых скобках, например, #include <cstdlib>) или заголовочных файлов сторонних библиотек (в этом случае название указывается в двойных кавычках, например, #include "sqlite3.h").

using namespace std
используется для выбора пространства имён std по-умолчанию. В библиотеках могут быть использованы различные пространства имён, ограничивающие область видимости функций, классов и глобальных переменных. В стандартной библиотеке используется пространство имён std, указывающее на то, что данная конструкция является частью стандартной библиотеки. Если не использовать никакое пространство имён, то даже при подключении заголовочного файла (например применив вызов #include <iostream>), мы не сможем явно использовать элементы этой библиотеки, которые объявлены в пространстве имён std. Т.е. вызов cout << "Привет, мир!" вызовет ошибку, что объект cout не найден. Это происходит потому, что данный объект имеет область видимости только внутри пространства имён std. Но мы можем его вызвать, явно указав, в каком пространстве имён следует искать данный объект. Для этого необходимо перед именем объекта указать имя пространства имён, в котором он находится. Пример:

#include <iostream>

int main()
{
     cout <<"Hello!"  // Ошибка - не указано пространство имён
     std::cout  <<"Hello!"  // Нет ошибки - вызов объекта из пространства имён std, указанного явным образом
}

как-то так...

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскале для вычисления произведение отрицательных. количество введенных чисел неизвестно, 0 – признак окончания ввода чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

novdodCT
Liliya1106
kate281078
annakuzina2023
Aleksandrovich-Yurevna1421
dianakryukova00
charlie79
Баринова
puma802
Galinagol559
zvezda-71
mkrtchyananaida6995
Кирилл-Анна1023
Руслан1360
zuzazuza61
▲