beliaeva2
?>

Максимум . нужно составить программу на паскале (ниже само если хотя бы два числа из трех введенных чисел положительны, то уменьшить каждое нечетное число на 1, иначе – найти сумму всех чисел.

Информатика

Ответы

strelnikov-aa

var a,b,c,kol:integer;

 begin

   readln(a,b,c);

if a>0 then inc(kol);

if b>0 then inc(kol);

if c>0 then inc(kol);

if kol>=2 then

                      begin

                        if a mod 2=1 then dec(a);

                        if b mod 2=1 then dec(b);

                        if c mod 2=1 then dec(c);

                      end

  else writeln(a+b+c);

end.

Объяснение:

sergei-pletenev

ответ: 48

Объяснение:

В любом двоичном числе каждая цифра будет 1 или 0. Причём, следует не забывать, что пятизначные числа, начинающиеся на 0, не считаются таковыми. Поэтому количество всех пятизначных двоичных чисел будет равно 2⁵ - 2⁴ = 32 - 16 = 16.

Все двоичные числа начинаются с 1, поэтому все первые цифры наших чисел будут единицами — это 16 единиц. Если чисел 16, каждая цифра (кроме первой) может принимать значение 1 либо 0, значит каждый последующий разряд всех чисел будет принимать 16/2 раз единицу и 16/2 раз ноль. Выходит всего по 8 единиц в каждом из 4 разрядов — это 32 единицы. 16 + 32 = 48.

ShafetdinovAndrei

СЖЗКБ

Объяснение:

Артём: з4 б5 к1

Борис: б2 з3 к5\

Вадим: к3 с2 б5

Глеб: з5 с1 к3

Дмитрий: б3 к4 з1

У каждого 1 верное предположение.    

У Артёма и Вадима общее предположение б5. Пусть это так. Тогда  предположения Бориса б2 и к5 неверные, те верное з3. У Глеба неверные з5 и к3, те с1 - правда. Мы знаем, что б5, з3 и с1. Значит верное предположение Дмитрия - к4, тк местоположение зелёного и белого шаров мы знаем. По остаточному принципу получим ж2.

Если это не так:

У обоих есть предположения о красном шаре. Рассмотрим их.

1) к1 верно. Тогда к3 и з4 неверно, но верно с2. У Бориса неверно к5 и б2, но верно з3. Получаем, что Глеб ничего не угадал, противоречие.

2)к3 верно. Тогда к1 и с2 неверно, но верно з4. У Бориса верно б2,

у Глеба к3, тк это предположение у них с Вадимом совпадает. Получим, что к3, б2, з4. И мы видим, что Дмитрий ничего не угадал, противоречие.

3) и к1, и к3 неверно. Тогда верно з4 и с2. Здесь Борис угадает к5.

Но снова ничего не угадает Глеб. Опять противоречие.

Получим, что белый шар действительно лежит в пятом ящике.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Максимум . нужно составить программу на паскале (ниже само если хотя бы два числа из трех введенных чисел положительны, то уменьшить каждое нечетное число на 1, иначе – найти сумму всех чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

onboxru16
dianabuchkina
alex091177443
serge-lysoff
tarasowamash4
tabacoffee
germanleon
Irinalobanowa
tokarevaiv
maslprod
cardiodoc08
Struev730
mamaevmvv3
ольга1801
palosik7621