Кирилл_Гульницкий
?>

Написать прогу на паскале: написать программу, подсчитывающую количество четных чисел от 5 до b (b вводится с клавиатуры

Информатика

Ответы

Марина Федорович924
{Заданиенаписать прогу на паскале:написать программу, подсчитывающую количество четных чисел от 5 до b (b вводится с клавиатуры).
}var b, k, i       : integer;
begin  writeln('Введите число b');  readln(b); //ввод числа b  k:=0; //зануляем счетчик  for i:= 5 to b do  begin      if (i mod 2 =0)then //mod остаток от деления                      k:=k+1;//увеличиваем счетчик если нашлось четное число  end;  writeln('k=',k); //вывод k  end.
SaraevaTretyakov1941
К внешним устройствам относятся:

устройства ввода информации;
устройства вывода информации;
диалоговые средства пользователя;
средства связи и телекоммуникации.

К устройствам ввода информации относятся:

клавиатура — устройство для ручного ввода в компьютер числовой, текстовой и управляющей информации;
графические планшеты (дигитайзеры) — для ручного ввода графической информации, изображений путем перемещения по планшету специального указателя (пера); при перемещении пера автоматически выполняется считывание координат его местоположения и ввод этих координат в компьютер;
сканеры (читающие автоматы) — для автоматического считывания с бумажных носителей и ввода в компьютер машинописных текстов, графиков, рисунков, чертежей;
устройства указания (графические манипуляторы) — для ввода графической информации на экран монитора путем управления движением курсора по экрану с последующим кодированием координат курсора и вводом их в компьютер (джойстик, мышь, трекбол, световое перо);
сенсорные экраны — для ввода отдельных элементов изображения, программ или команд с полиэкрана дисплея в компьютер).

К устройствам вывода информации относятся:

графопостроители (плоттеры) — для вывода графической информации на бумажный носитель;
принтеры — печатающие устройства для вывода информации на бумажный носитель.
Aliferenko
1)

1 + «Кнопка 5» = 6 этаж

6 + «Кнопка -3» = 3 этаж

3 + «Кнопка 5» = 8 этаж

8 + «Кнопка -3» = 5 этаж

5 + «Кнопка -3» = 2 этаж

2 + «Кнопка 5» = 7 этаж

7 + «Кнопка -3» = 4 этаж

4 + «Кнопка 5» = 9 этаж


2)

Боря мог выиграть все 9 раз:

1. 3 раза Боря показал камень, Алёша – ножницы

2. 4 раза Боря показал ножницы, Алёша – бумагу

3. 2 раза Боря показал бумагу, Алёша – камень


Алёша мог выиграть не более 7 раз:

1. Алёша показывает камень, Боря показывает ножницы – 2 раза. - победа

2. Алёша показывает ножницы, Боря показывает бумагу – 2 раза. - победа

3. Алёша показывает бумагу, Боря показывает камень – 3 раза. - победа

4. Алёша показывает бумагу, Боря показывает ножницы – 1 раз. - поражение

5. Алёша показывает ножницы, Боря показывает ножницы – 1 раз. – поражение

Результат:

Боря мог выиграть 9 раз.

Алёша мог выиграть 7 раз.


3)

Камнев – К, Ножницын – Н, Бумагин - Б

1. Перевезти баулы К

2. Перевезти каждый баул Н по очереди с Н в лодке, баулы оставить, Н вернуть.

3. Перевезти каждый баул Б по очереди с Б в лодке, баулы оставить, Б вернуть.

4. Перевезти Б, Н и К

4)

Для каждой гирьки есть 3 возможных расположения: чаша с грузом (-1), противоположная чаша (1) или вообще не ставить (0). Расположение каждого груза можно выбирать независимо, поэтому если есть n грузов, то их можно разместить Исходя, из этого 3^2<10<3^3, 2 гирьки - как минимум 1 значение останется без решения, 3 гирьки - как минимум 1 будет иметь несколько решений. Оптимальным набором гирек является тот, который содержит в себе степени какого либо числа: Степени двойки не подходят потому как не используют обе части весов; Тройки же подходят, поскольку гири располагаются на разных чашах весов, то их вес относительно взвешиваемого груза может принимать и положительное, и отрицательное значение.

Если, к примеру, нужна гиря весом в 2 единицы, то нужно на чашу весов с грузом положить гирю с весом 1, а на противоположную с весом 3. Вес 1 вычитается из 3 и результат 2. Таким образом можно взвесить любую массу от 1 до 10.

Возьмем 3 гирьки массой: 1, 3, 9 (степени тройки)

Цифра со знаком «-» будет соответствовать гирьке на другой чашке весов.

Уравновешивания всех масс от 1 до 10:

1 = 1.

2 = 3 - 1,

3 = 3,

4 = 3 + 1,

5 = 3 + 3 - 1,

6 = 3 + 3,

7 = 9 - 1 - 1,

8 = 9 - 1,

9 = 9,

10 = 9 + 1

5)

Допустим, минимальное количество шагов получится если постоянно удваивать максимальное значение:

1) Х+Х=2Х 2) 2Х+2Х=4Х 3) 4Х+4Х=8Х(8X+8X>15X) 4)8Х+4Х=12Х 5)12Х+2Х=14Х 6)14Х+Х=15Х – 6 шагов

Иначе, получить максимальное кратное число (неравное 15): 1, 3, 5 – максимальное 5.

Что бы его получить нужно сделать как минимум 3 операции:

1) Х+Х=2Х 2) 2Х+2Х=4Х 3) 4Х+Х=5Х

Или

1) Х+Х=2Х 2) 2Х+Х=3Х 3) 3Х+2Х=5Х

Теперь, нужно сделать (15/5)-1 операций для получения самого числа

4) 5Х+5Х=10Х 5) 10Х+5Х=15Х

ответ(5 шагов):

1) Х + Х = 2Х

2) 2Х + Х = 3Х

3) 3Х + 2Х = 5Х

4) 5Х + 5Х = 10Х

5) 10Х + 5Х = 15Х

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать прогу на паскале: написать программу, подсчитывающую количество четных чисел от 5 до b (b вводится с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

stasyan
andyrvo
Есартия52
om805633748
kuchino09
siger06297
kzhgutova
Aleksandrivanovna
Mikhail_Magomed635
Yelena_Yuliya1847
svetsalikowa
serg1976g
михаил
Dmitrii sergei463
mmihail146