atlantika7
?>

Найти площадь равнобедренной трапеции с основаниями a и b и углом α при большем основании a: составить программу. pascal abc.

Информатика

Ответы

david-arustamyan1
Var a,b,q:integer;
s,h:real;
begin
clrscr;
writeln('Введите основания');
readln(a,b);
writeln('Введите угол в градусах');
readln(q);
h:=(abs(a-b)/2)*sin(q*pi/180)/cos(q*pi/180);
s:=((a+b)*h)/2;
writeln('Площадь=',s:1:2);
readkey;
readln;
end.
PivovarovaIlina1437

C#

string a;

           ConsoleKeyInfo keyInfo;

           do

           {

               Console.WriteLine("Введите одну из перечисленных стран:\n*Венгрия\n*Италия\n*Греция\n*Турция\n*Египет\n*Непал\n*Бельгия\n");

               a = Convert.ToString(Console.ReadLine());

               switch (a)

               {

                   case ("Венгрия"):

                       Console.WriteLine("Столица: Будапешт\nНаселение: 9,7 млн чел.\n");

                       break;

                   case ("Италия"):

                       Console.WriteLine("Столица: Рим\nНаселение: 60 млн чел.\n");

                       break;

                   case ("Греция"):

                       Console.WriteLine("Столица: Афины\nНаселение: 10 млн чел.\n");

                       break;

                   case ("Турция"):

                       Console.WriteLine("Столица: Анкара\nНаселение: 55 млн чел.\n");

                       break;

                   case ("Египет"):

                       Console.WriteLine("Столица: Каир\nНаселение: 53 млн чел.\n");

                       break;

                   case ("Непал"):

                       Console.WriteLine("Столица: Катманду\nНаселение: 29 млн чел.\n");

                       break;

                   case ("Бельгия"):

                       Console.WriteLine("Столица: Брюссель\nНаселение: 11 млн чел.\n");

                       break;                    

                   default:

                       Console.WriteLine("Неверно введены данные\n");

                       break;

               }    

               

               Console.WriteLine("Если хотите повторить программу нажмите F");

               Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");

               keyInfo = Console.ReadKey(true);

           }

           while (keyInfo.Key == ConsoleKey.F);


2. Напишите программу, которая при наборе с клавиатуры названия страны выводит на экран название сто
verkop9

1.

int - целые числа

float - числа с плавающей точкой (вещественные)

list - списки

str - строки

bool - логический (булевый) тип

2.

3.14, 0.5 - float

-10, 0, 55 - int

true, false - bool

"Информатика", "computer", "321" - str

3. Деление (/)

Объяснение:

Типы:

1) int - целые числа могут быть любой длины, они ограничиваются лишь доступной памятью

2) float - числа с плавающей точкой (вещественные, дробные) имеют ограниченную точность. На экране разницу между целым числом и числом с плавающей точкой можно заметить по наличию точки:

1 - целое число

1.0 - число с плавающей точкой

3) list - списки - упорядоченные последовательности элементов. Элементы списка не обязательно должны быть одного типа.

4) str - строки - последовательность символов. Для создания строки используются кавычки.

5) bool - логический (булевый) тип. Принимают одно из двух значений: True или False.

При делении частное (результат) всегда будет числом с плавающей точкой, даже если в нём участвуют два целых числа.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найти площадь равнобедренной трапеции с основаниями a и b и углом α при большем основании a: составить программу. pascal abc.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

svetkinm158
bas7572513
Adassa00441
marketing6
Seid-ZadeNadezhda1769
masum-2011687
Aleksandrovich_Mitoyan1138
delo1005
Borisovich-Volobueva1803
skorpion7228528
info-mosbalkon
orgot9
Nikolaevna1623
oslopovavera
d2002