Galina-3639220565
?>

Визначити кількість слів у довільному рядку (паскаль або лазарус)​

Информатика

Ответы

Андреевна-Арзуманян1109

1)

var

i,c:integer; //Объявляем переменные

mas: array [1..20] of integer; //Объявляем массив

begin

c:=0; //Обнуляем переменную c

writeln('20 случайных чисел:'); //выводим на экран сообщение

randomize; //запускам рандом

for i:=1 to 20 do begin //запускаем цикл для массива от 1го до 20го элемента по очереди

mas[i]:=random(5,20); //генерируем число от 5 до 20

if mas[i] mod 2 = 0 then begin //запускам проверку, на четность числа. Если оно делится без остатка на 2

c:=c+1; //то к переменной c прибавляем единицу (значит оно четное

end;

write(mas[i], ' '); //Выводим наш массив

end;

writeln(); //пробел между строк

writeln('Количество четных элементов = ', c); //выводим количество четных элементов  

end.

2)

var

i:integer; //Объявляем переменные

s:real; //Объявляем переменные

mas: array [1..10] of real; //Объявляем массив

begin

writeln('Введите 10 вещественных чисел'); //выводим на экран сообщение

for i:=1 to 10 do begin //запускаем цикл заполнения массива

read(mas[i]); //вводим число с клавиатуры

if mas[i] < 1 then //проверяем меньше ли единицы введенное число

s:=s+mas[i]; //если меньше,то прибавляем его в сумму (считаем сумму всех чисел, меньше 1, чтобы найти среднее арифметическое)

end;

s:=s/10; //Делим сумму на количество чисел  

writeln ('Среднее арифметическое = ',s);

end.

Мария1414
Var a,b,c: integer; begin writeln('введите три числа'); readln(a,b,c); if (a< =b)and(b< =c) then write(a,' ',b,' ',c) else if (a< =c)and(c< =b) then write(a,' ',c,' ',b) else if (b< =a)and(a< =c) then write(b,' ',a,' ',c) else if (b< =c)and(c< =a) then write(b,' ',c,' ',a) else if (c< =a)and(a< =b) then write(c,' ',a,' ',b) else if (c< =b)and(b< =a) then write(c,' ',b,' ',a) end. var a,b,c,d: real; begin write('a = '); readln(a); write('b = '); readln(b); write('c = '); readln(c); d: =b*b-4*a*c; if d> =0 then     begin     writeln('x = '-sqrt(d))/(2*a));     writeln('x = '+sqrt(d))/(2*a));     end else writeln('действительных корней нет') end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Визначити кількість слів у довільному рядку (паскаль або лазарус)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

VadimovnaIgor
bestform
Chikichev456
Igorevich1512
osirparts7854
maksteks
Акимцева27
viz-art-pnz1664
Дмитрий_Владимирович1162
konstantinslivkov
Корягина
aleksagrbec39
Суравцова_Алексей669
Составить программу на Pascal. Y=34c+(12m/7n)
Nivanova995
▲