Pastel-sova
?>

Решить на составление программы линейной структуры с переменной: 1. заработок рабочих на фабрике составил 624750 руб. его нужно разделить поровну между а рабочих и k служащих. выведите заработок каждого работника. 2. мальчик может бегать в 3 раза быстрее, чем ходить. скорость его ходьбы равна y км/ч. он принял участие в марафонском забеге, но сошел с дистанции, пробежав только x км. сколько времени он затратил на преодоление этого расстояния.

Информатика

Ответы

oskar-pn
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
  Writeln('Заработок работника равен ',624750/(a+k))
end.

Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750

№2

begin
  var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
  var x:=ReadReal('Мальчик пробежал, км: ');
  Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.

Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км:  12
Затрачено времени на бег, ч: 0.77
Анна Марина1873
К сожалению, ты не написал на каком тебе надо языке, я выбрал JavaScript
1) var array = [4,5,10,-10,5]; 
var min = 1000000;
for (var i = 0; i < 5; i++) {
if (min>array[i]) {
min = array[i];
 }
 }
alert("Минимальный элемент + "min);

2)var array = [];
for (var i = 0; i < 5; i++) {
var number = prompt("Введите число");
 array.push(number);
}
alert("Ваш массив " + array);
var min = 1000;
var max = 0;
for (var j = 0; j < 5; j++) {
  if (min > array[j]) {
  min = array[j];
  }
}
alert("Минимум = " + min);
for (var k = 0; k < 5; k++) {
if (max < array[k]) {
  max = array[k];
 }
}
alert("Максимум = " + max);
mar1030

Задачка мне очень понравилась, прилагаю решение на C#, консольное приложение

Объяснение:

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;

namespace Археологи_строители

{ class Program

   {

       static void Main(string[] args)

       {

           //Объявляем и задаем переменные "M" и "N", а так же переменную для результата

           int M,N=new int();

           int MyResult = 0;

           Console.WriteLine("Ведите Текущее количество ступенек и Сколько их должно быть:");

           M = int.Parse(Console.ReadLine());

           N = int.Parse(Console.ReadLine());

           // Создаем массив для хранения данных о ступенях. M-Количество ступенек, Цифра - для колонок длины и высоты

           int[,] mass = new int[M,2];

           // Запись значений в массив

           for (int x = 0; x < M; x++){

               for (int y = 0; y < 2; y++){

                   if (y==0){  //Чисто для юзерфрендли отображения

                       Console.Write($"Введите значение Длины для ступеньки №{x + 1}= ");} else{

                       Console.Write($"Введите значение Высоты для ступеньки №{x + 1}= ");}

                   mass[x, y] = Convert.ToInt32(Console.ReadLine());}

                   Console.WriteLine();}

           /* Как оказалось, самый простой определить какую же ступеньку надо "поднимать"-

            * это вычислить площадь гипотетически "заполняемого" пространства над ступенькой и взять

            * наименьшее значение.

            *  

            * Итак, допустим если у нас 5 ступенек, то нам нам необходимо записать 4 значения

            * (в рамках лестницы) площади заполняемых ступенек.

            *  

            * Перемножаем Длину ступеньки N на высоту ступеньки N+1, M-1 раз и сохраняем в массив

            */

           int M2 = M; //Дублируем изначальное число ступенек для контроля цикла

           for (int z = 0; z <M2-N; z++)

           {

               int[] acreage = new int[M - 1];

               for (int x = 0; x < M - 1; x++)

               {

                   for (int y = 0; y < 2; y++)

                   {

                       acreage[x] = mass[x, 0] * mass[x + 1, 1];

                   }

               }

               /*

                * И так у нас есть все значения гипотетически заполняемой ступеньки.

                * Ищем минимальное значение площади  

                */

               int minAcreage = acreage[0];

               for (int i = 0; i < M - 1; i++)

               {

                   if (minAcreage > acreage[i])

                   {

                       minAcreage = acreage[i];

                   }

               }

               MyResult = MyResult+minAcreage; //Плюсуем данное значение в переменную результата

               // У нас есть минимальная площадь. Найдем номер данной ступеньки

               int IndexAcreage = Array.IndexOf(acreage, minAcreage);

               //"Достроим нужную нам ступеньку и запишем обновленные данные во временный массив"

               int[,] tempMass = new int[M - 1, 2]; //Он на размер меньше, т.к. и "полных" ступенек у нас стало меньше

               for (int x = 0; x < M - 1; x++)

               {

                   for (int y = 0; y < 2; y++)

                   {

                       //Ступеньки до IndexAcreage мы просто переписываем во временный массив

                       if (x < IndexAcreage)

                       {

                           tempMass[x, y] = mass[x, y];

                       }

                       //2 ступеньки от IndexAcreage мы превращаем в одну (застраивая их блоками)

                       else if (x == IndexAcreage)

                       {

                           tempMass[x, y] = mass[x, y] + mass[x + 1, y];

                       }

                       /* и после IndexAcreage мы та же копируем, но со сдвигом вправо, т.к. полноценных  

                        * ступенек стало меньше

                        */

                       else if (x > IndexAcreage)

                       {

                           tempMass[x, y] = mass[x + 1, y];

                       }

                   }

               }

               M = M - 1; //Поскольку ступенек теперь меньше, то и их фактическое число необходимо уменьшить

               for (int x = 0; x < M + 1; x++)

               {

                   for (int y = 0; y < 2; y++)

                   {

                       mass[x, y] = 0;

                   }

               }

               //переписываем данные в основной массив и запускаем следющую интерацию цикла

               for (int x = 0; x < M; x++)

               {

                   for (int y = 0; y < 2; y++)

                   {

                       mass[x, y] = tempMass[x, y];

                   }

               }

           }

           Console.WriteLine($"Минимально необходимое число блоков: {MyResult}");

           Console.ReadKey(true);

       }

   }

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на составление программы линейной структуры с переменной: 1. заработок рабочих на фабрике составил 624750 руб. его нужно разделить поровну между а рабочих и k служащих. выведите заработок каждого работника. 2. мальчик может бегать в 3 раза быстрее, чем ходить. скорость его ходьбы равна y км/ч. он принял участие в марафонском забеге, но сошел с дистанции, пробежав только x км. сколько времени он затратил на преодоление этого расстояния.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleksey19801
fetisov68av
Васильевичь Виктория457
Vladimirovna Viktorovna
abdulhakovalily22
oloinics
Vitalevna1186
veronica1344
ooozita5
dashkevich-76611
Людмила902
ekaterinkat
zotcet7
ivan-chay19
iplizogub74