Людмила902
?>

60 напишите программу на c++, которая моделирует работу процессора. процессор имеет 4 регист-ра, они обозначаются r0, r1, r2 и r3. все команды состоят из трех десятичных цифр: код операции, номер первого регистра и номер второго регистра (или число от 0 до 9 коды команд и примеры их использования в таблице: код операции описание пример псевдокод1 запись константы 128 r2: =82 копирование значения 203 r3: =r03 сложение 331 r1: =r1+r34 вычитание 431 r1: =r1-r3обратите внимание, что результат записывается во второй регистр. команды вводятся последовательно как символьные строки. после ввода каждой строки программа показывает значения всех регистров.​

Информатика

Ответы

olimp201325

ответ:#include <bits/stdc++.h>

using namespace std;

int main() {

const int x = 3, y = 4;

int N[x], M[y] = { 0, 0, 0, 0 };

int r = 0;

do {

 r = 0;

 for (int q = 0; q < x; q++) {

  N[q] = getchar() - 48;

  if (N[q] == -38) q--;

  if (N[q] == 0) r++;

 }

 switch (N[0]) {

 case 1: M[N[1]] = N[2]; break;

 case 2: M[N[2]] = M[N[1]]; break;

 case 3: M[N[2]] = M[N[2]] + M[N[1]]; break;

 case 4: M[N[2]] = M[N[2]] - M[N[1]]; break;

 }

 for (int e = 0; e < y; e++) {

  cout << "R" << e << " = " << M[e] << "\n";

 }

} while (r != x);

return 0;

}

Объяснение:

liza04521160
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
makashi28

1. Образовательные:

сформировать представления о назначении и принципах построения локальных компьютерных сетей;

сформировать знания о составе и основах функционирования локальных компьютерных сетей;

2. Развивающие:

развить познавательные и творческие учащихся;

развить образное мышление;

развивать готовность учащихся к информационно-учебной деятельности, применять инструментальные средства и средства информационных технологий в любом предмете для реализации учебных целей и саморазвития.

3. Воспитательные:

воспитывать трудолюбие, ответственность за результаты своего труда:

воспитывать культуру делового общения при совместной работе в группе;

воспитывать доброжелательность среди учащихся, нацеленность на результативность обучения.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

60 напишите программу на c++, которая моделирует работу процессора. процессор имеет 4 регист-ра, они обозначаются r0, r1, r2 и r3. все команды состоят из трех десятичных цифр: код операции, номер первого регистра и номер второго регистра (или число от 0 до 9 коды команд и примеры их использования в таблице: код операции описание пример псевдокод1 запись константы 128 r2: =82 копирование значения 203 r3: =r03 сложение 331 r1: =r1+r34 вычитание 431 r1: =r1-r3обратите внимание, что результат записывается во второй регистр. команды вводятся последовательно как символьные строки. после ввода каждой строки программа показывает значения всех регистров.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Федорович Шахова241
Galinagol559
yahottabych201379
janepustu
billl24
alplakhota67
belegaj98
lider123
natalili32
yrgenson2011801
merzlikinairena
Kolokolnikova DANIIL179
nickname0091
Олеся
AndrukhovichKonovalov
ДЗ: elt7-1, №1-7. Помагите