Назаренко1075
?>

Тест описание разработки 1. определите значение переменной k, после выполнения фрагмента программы: n: = 'обработка строк в паскаль'; k: = length (n); write (k); ответ: 2. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; delete (n, 10, 8); write (n); ответ: 3. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; insert ('оч', n, 8); write (n); ответ: 4. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; k: = copy (n, 19, 7); write (k); ответ: 5. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; k: = copy (n, 1, 1); delete (n, 1, 20); insert (k, n, 0); delete (n, 6, 1); write (n); ответ: 6. определите значение переменной k, если n: = 'обработка строк в паскаль'; for i: = 1 to length (n) do if n[i] = 'а' then inc (k); write (k); ответ: 7. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; for i: = 1 to length (n) do if n[i] = 'о' then n[i]: = ' '; write (n); ответ:  8. определите начальные значения переменных a и b, если поле выполнения фрагмента программы программа вывела на экран “! как дела? ” (без кавычек)? c: = b + a; insert (' как ', c, 8); write (c); ответ: 9. какую фразу можно записать в переменную x, чтобы после выполнения фрагмента программы переменная kприняла значение 6? можнонаписать пример. k: = 10; for i: = 1 to length (x) do if x[i] = ' ' then dec (k); write (k); ответ: 10. что будет выведено на экран после выполнения программы? var s: string; i: integer; begin s: ='s'; for i: = 1 to 3 do s: = s + 'о'; write (s + 's'); end. ответ:

Информатика

Ответы

Алла14
1) 25
2) Обработка Паскаль
3) Обработочка строк в Паскаль
4) Паскаль
5) Оскал
6) 4
7) Обраб тка стр к в Паскаль
8) a:=дела? | b=Привет!
9) В Паскакль есть много функций (вообще любую фразу состоящую из 5 слов, символов отделенных пробелом)
10) SоооS
alenaya69918
1)
#include<iostream>
#include<cmath>  
void main() {    
char ch1, ch2;    
int vol1, vol2;          
std::cin >> ch1 >> vol1;        
std::cin >> ch2 >> vol2;                            
if abs(ch1 - ch2) <= 2) && (abs(vol1 - vol2) <= 2)) && ((ch1 != ch2) && (vol1 != vol2))) && !((abs(ch1 - ch2)==1) && (abs(vol1-vol2))==1))             std::cout << "Possible";                    
else            
std::cout << "Impossible";        
}
3)
#include<iostream> 
using namespace std; 
void main() {    
int n,m;
cin >> n,m;
cout<<n;
for(int i=n;i<=m;i++)
cout<<i+2;
}
4)

#include <iostream>
using namespace std; void main(){
int mass[2][4]   //размерность своего массива вписывай.
{
{ 1, 2, 3, 4 },  //вписывай свои числа.
{ 1, 2, 3, 4 }  
};

for (int i=0 ; i<2;++i)
{
for (int j=0 ; j<4;++j)
{
if(mass[i][j]<0)
 cout<<mass[i][j];
}
}
system("pause");
}

 
stolle16
// PascalABC.NET 3.0, сборка 1128
procedure Convert(V:array of integer);
begin
  for var i:=0 to V.Length-1 do
    if V[i]>9 then V[i]:=9
    else
      if V[i]<5 then V[i]:=5
end;

procedure Develop(c:char; k:integer);
begin
  WritelnFormat('*** Массив {0} ***',c);
  var a:=ArrRandom(k,-5,15);
  Write('исходный : '); a.PrintLn(',');
  Convert(a);
  Write('результат: '); a.PrintLn(',');
end;

begin
  var m:=ReadInteger('Количество элементов в массиве A:');
  var n:=ReadInteger('Количество элементов в массиве B:');
  Develop('A',m);
  Develop('B',n)
end.

Тестовое решение:
Количество элементов в массиве A: 15
Количество элементов в массиве B: 10
*** Массив A ***
исходный : 6,5,-5,9,1,0,-3,9,13,12,-4,8,11,14,-5
результат: 6,5,5,9,5,5,5,9,9,9,5,8,9,9,5
*** Массив B ***
исходный : 5,12,12,4,7,9,7,-3,-1,-2
результат: 5,9,9,5,7,9,7,5,5,5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Тест описание разработки 1. определите значение переменной k, после выполнения фрагмента программы: n: = 'обработка строк в паскаль'; k: = length (n); write (k); ответ: 2. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; delete (n, 10, 8); write (n); ответ: 3. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; insert ('оч', n, 8); write (n); ответ: 4. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; k: = copy (n, 19, 7); write (k); ответ: 5. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; k: = copy (n, 1, 1); delete (n, 1, 20); insert (k, n, 0); delete (n, 6, 1); write (n); ответ: 6. определите значение переменной k, если n: = 'обработка строк в паскаль'; for i: = 1 to length (n) do if n[i] = 'а' then inc (k); write (k); ответ: 7. определите результат работы следующего фрагмента программы: n: = 'обработка строк в паскаль'; for i: = 1 to length (n) do if n[i] = 'о' then n[i]: = ' '; write (n); ответ:  8. определите начальные значения переменных a и b, если поле выполнения фрагмента программы программа вывела на экран “! как дела? ” (без кавычек)? c: = b + a; insert (' как ', c, 8); write (c); ответ: 9. какую фразу можно записать в переменную x, чтобы после выполнения фрагмента программы переменная kприняла значение 6? можнонаписать пример. k: = 10; for i: = 1 to length (x) do if x[i] = ' ' then dec (k); write (k); ответ: 10. что будет выведено на экран после выполнения программы? var s: string; i: integer; begin s: ='s'; for i: = 1 to 3 do s: = s + 'о'; write (s + 's'); end. ответ:
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

deniskotvitsky56
sleek73
Tuzov
chaa140
hristos1212
uchpaot
innavinogradova1385
sashakrotova943
nash-crimea2019
Ladyby6224
Yurevich
Татьяна-Мария
annakuzina2023
tarasova
strannaya2018
▲