Oksana373
?>

Создать программу python напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. пример: введите два числа: 10 -15 10*(-15)=-150

Информатика

Ответы

Maria095096
A=int(input('a = '));
b=int(input('b = '));
if (((a<0) & (b>0)) | ((a>0) & (b<0))): sgn=1;
else: sgn=0;
if (a<0): a=-a;
if (b<0): b=-b;
c=0;
while (a>0):
    if ((a & 1)==1): c+=b;
    a>>=1;
    b<<=1;
if (sgn==1): print('результат: ',-c);
else: print('результат: ',c);

a = - 42153689754
b = 7892456310201
результат:  - 332696154697212539380554
    
Теплова

1. Из двух простых высказываний постройте сложное высказывание, используя

логические связки «и», «или»:

а) В кабинете есть парты. В кабинете есть стулья.

б) Одна половина класса изучает английский язык. Вторая половина изучает

французский язык.

в) Антон старше Лили. Сережа старше Лили.

2. Вычислите значение логического выражения при следующих значениях логических

величин А, В и С: А=Истина, В=Ложь, С=Ложь:

а)А или В; б)А и В; в)В или С.

3. Определите тип высказывания и вид логической операции с соответствующей

логической связкой:

a) Всякий прямоугольник имеет прямые углы и параллельные противоположные

стороны;

б) Треугольники с равными сторонами не являются равнобедренными;

в) На следующем уроке будет либо история, либо химия;

г) Завтра я пойду в школу и библиотеку;

д) Либо он заболел, либо забыл о нашей договорённости;

е) Утром мы обычно ходим на

Объяснение:

Olegmgu11986

1. Из двух простых высказываний постройте сложное высказывание, используя

логические связки «и», «или»:

а) В кабинете есть парты. В кабинете есть стулья.

б) Одна половина класса изучает английский язык. Вторая половина изучает

французский язык.

в) Антон старше Лили. Сережа старше Лили.

2. Вычислите значение логического выражения при следующих значениях логических

величин А, В и С: А=Истина, В=Ложь, С=Ложь:

а)А или В; б)А и В; в)В или С.

3. Определите тип высказывания и вид логической операции с соответствующей

логической связкой:

a) Всякий прямоугольник имеет прямые углы и параллельные противоположные

стороны;

б) Треугольники с равными сторонами не являются равнобедренными;

в) На следующем уроке будет либо история, либо химия;

г) Завтра я пойду в школу и библиотеку;

д) Либо он заболел, либо забыл о нашей договорённости;

е) Утром мы обычно ходим на

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать программу python напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. пример: введите два числа: 10 -15 10*(-15)=-150
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ekvld708
MArat
baron
Dmitrievich-Telishev
Less2014
chavagorin
Андрей_Станиславовна
Polina780
Semenovt
Руслан1360
gaydukov5706
llipskaya
R7981827791127
Aleksei368
sorokinae