?>
Составить программу. в текстовом файле дано произвольное сообщение. вычислить, какое количество информации (в битах) в нем содержится. для этого: • выяснить, в каком алфавите написан текст (сколько и какие различные буквы встречаются в тексте) • найти количество символов в тексте и количество вхождений каждой буквы алфавита в текст • вычислить вероятность вхождения каждой буквы алфавита в текст • вычислить количество информации, которую несет один символ в тексте (формула шеннона) • вычислить количество информации, которую несет все сообщение
Ответы
public static void main(String args[]){
java.util.Scanner in = new java.util.Scanner(System.in);
String string = in.nextLine(); char chars[] = new char[4];
chars[0] = in.nextLine().charAt(0); chars[2] = in.nextLine().charAt(0);
for(int sChar = 0; sChar<string.length(); sChar++)
if(string.charAt(sChar)==chars[0])chars[1]++;
else if(string.charAt(sChar)==chars[2])chars[3]++;
System.out.print("\n"+(chars[1]==chars[3]?chars[0]+""+chars[2]:chars[1]>chars[3]?chars[0]:chars[2]));
}
}