Окунева-Мотова
?>

Составить программу которая показывает количество чётных чисел между числами а и б. с клавиатуры вводятся два числа а выводится количество чётных чисел между ними. ! !

Информатика

Ответы

Daulyatyanov1266
Program HelloWorld;var a,b,c,i:integer;begin    readln(a);    readln(b);    c:=0;    for i:=a to 10 do    if (i mod 2=0) then inc(c);    writeln(c);end.
irinanikulshina144
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
procedure MatPrint(a:array[,] of integer);
begin
  for var i:=0 to Length(a,0)-1 do begin
    for var j:=0 to Length(a,1)-1 do Write(a[i,j]:4);
    Writeln
    end
end;

procedure MatReplaceOdd(a:array[,] of integer; value:integer);
begin
  for var i:=0 to Length(a,0)-1 do
    for var j:=0 to Length(a,1)-1 do
      if a[i,j].IsOdd then a[i,j]:=value
end;

begin
  var n,m:integer;
  Write('Задайте число строк и столбцов матрицы: ');
  Read(n,m);
  var a:=MatrixRandom(n,m,-99,99);
  Writeln('Исходный массив');
  MatPrint(a);
  MatReplaceOdd(a,26);
  Writeln('Результирующий массив');
  MatPrint(a)
end.

Тестовое решение
Задайте число строк и столбцов матрицы: 5 7
Исходный массив
 -14  86  52 -85 -52 -79  78
  20 -80  68  89 -45 -45 -36
 -41 -60  96  43  16  56 -58
 -39  81   1  26 -15 -98  89
  57 -51  79 -28 -24 -63 -74
Результирующий массив
 -14  86  52  26 -52  26  78
  20 -80  68  26  26  26 -36
  26 -60  96  26  16  56 -58
  26  26  26  26  26 -98  26
  26  26  26 -28 -24  26 -74
fedchenkoofficial
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=ArrRandomReal(28,0.001,2); a.Println;
  Writeln(NewLine,'P=',a.Where(x->x<1.0).Aggregate(1.0,(p,x)->p*x))
end.

Тестовое решение
0.0398313784756844 0.521430412644721 1.21896472712139 1.94948843003553 1.15333909315725 0.788220413078657 0.284177359403659 1.78978303515016 0.678028235740042 1.55275635141682 0.189534365820482 0.741079475998916 1.8561824476473 1.56863753180655 1.46180190814184 0.424840159483645 1.72583213937042 1.9121896329998 1.74689281148598 1.49191368740467 0.900698237893031 0.867495573381193 1.51968024434926 1.28361295387922 0.144896066409953 0.40525055964489 0.897010715250862 1.71948831971571

P=7.74656862552087E-06

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая показывает количество чётных чисел между числами а и б. с клавиатуры вводятся два числа а выводится количество чётных чисел между ними. ! !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ninaandreeva3179
sastakhova
Nevstrueva_Vasilevna
skorpion7228528
rusdtver
Матвеев
vovkiv7864
olyavoznyak
Андреевич
kisuhakisa
Mark-Petrovich
KononovaMaiorov453
oniks-plus
egamedicalbuh
aquilonis