Mark-Petrovich
?>

Дан код программы, который выводит длину строки. abc = ''print(len(abc))Задача 1 написать программу, которая вводит строку и выводит 2 строки, первую и вторую половину строки.Вы находитесь магазине и у вас на руках купюра с номиналом 20 000 тенге. Вы хотите купить три товара с ценой не более 6 000 тенге. Напишите программу, которая принимает на ввод 3 числа (стоимость товаров) и выдает размер сдачи от 20 000 тенге.​

Информатика

Ответы

kapral1812
Задача №1
var a:array[1..4, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 4 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов кратных 3-м и > 20 = ',k); 
end.

Задача №2
var a:array[1..5, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 5 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if i=j then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов главной диагонали = ',k); 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан код программы, который выводит длину строки. abc = ''print(len(abc))Задача 1 написать программу, которая вводит строку и выводит 2 строки, первую и вторую половину строки.Вы находитесь магазине и у вас на руках купюра с номиналом 20 000 тенге. Вы хотите купить три товара с ценой не более 6 000 тенге. Напишите программу, которая принимает на ввод 3 числа (стоимость товаров) и выдает размер сдачи от 20 000 тенге.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

andyrvo
krasnobaevdj3
Melnik Kaveshnikova1746
nzagrebin363
Cannabikh
uchpaot
Olgachalova111
Yevgenii1423
Aleksey19801
tvtanya80
vadimkayunusov
maxkuskov2485
Матвеев
Segyn1218
Суховодова599