diana0720
?>

По введенному с клавиатуры номеру месяца определить, к какому времени года он относится и какие месяцы являются для данного предыдущим и последующим. составить программу в паскале.

Информатика

Ответы

andreyshulgin835
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var mn:=Arr('январь','февраль','март','апрель','май','июнь',
      'июль','август','сентябрь','октябрь','ноябрь','декабрь');
  var n:=ReadInteger('Номер месяца');
  case n of
  12,1,2:Write('Зима');
  3,4,5:Write('Весна');
  6,7,8:Write('Лето');
  9,10,11:Write('Осень');
  else begin
    Writeln('Неверный номер');
    exit
    end
  end;
  Writeln(', ',mn[n-1],', предшествующий ',n=1?mn[11]:mn[n-2],
      ', следующий ',n=12?mn[0]:mn[n])
end.

Пример
Номер месяца 2
Зима, февраль, предшествующий январь, следующий март
Stryapunina
//PascalABC.NET
//Версия 3.3, сборка 1634 (14.02.2018)

begin
  var mes:=Arr('Январь','Февраль','Март','Апрель','Май','Июнь','Июль','Август','Сентябрь','Октябрь','Ноябрь','Декабрь');
  var x:=ReadInteger('Введите номер месяца->');
  case x of
  12,1,2: Println('Зима');
  3,4,5: Println('Весна');
  6,7,8: Println('Лето');
  9,10,11: Println('Осень');
  else begin Println('Такого месяца нет'); exit; end; end;
  Println('Месяц:',mes[x-1]);
  if x=12 then Println('Следующий:',mes[0]) else Println('Следующий:',mes[x]);
   if x=1 then Println('Предыдущий:',mes[11]) else Println('Предыдущий:',mes[x-2]);
end.

Пример:
Введите номер месяца-> 12
Зима 
Месяц: Декабрь 
Следующий: Январь 
Предыдущий: Ноябрь 
Каныбек698

Объяснение:

Стиль форматирования — набор элементов форматирования (шрифта, абзаца и пр.), имеющий уникальное имя. Любой абзац документа Word оформлен определенным стилем, стандартным или пользовательским.

В Word существует четыре основных вида стилей:

стили символов;

стили абзацев;

стили таблиц;

стили списков.

Стилевое форматирование имеет ряд преимуществ перед ручным:

экономит время. Применить стиль как набор элементов форматирования значительно быстрее, чем применять их один за другим.

единообразию оформления документа. При ручном форматировании одинаковые по смыслу форматирования разделы могут отличаться своими форматами, применение стиля же вносит строгость в оформление документа.

позволяет быстро изменить вид отдельных элементов во всем документе. В этом случае достаточно внести изменения в стиль, и оформление вступит в силу во всем документе.

Стили абзацев обычно объединяют элементы форматирования символов и абзацев и определяют вид абзаца.

Тресков946

первоначально исследовавшая количественные отношения и пространственные формы[2]; более современное понимание: это наука об отношениях между объектами, о которых ничего не известно, кроме описывающих их некоторых свойств, — именно тех, которые в качестве аксиом положены в основание той или иной математической теории[3].

Математика исторически сложилась на основе операций подсчёта, измерения и описания формы объектов[4]. Математические объекты создаются путём идеализации свойств реальных или других математических объектов и записи этих свойств на формальном языке.

Математика не относится к естественным наукам, но широко используется в них как для точной формулировки их содержания, так и для получения новых результатов. Математика — фундаментальная наука, предоставляющая (общие) языковые средства другим наукам; тем самым она выявляет их структурную взаимосвязь и нахождению самых общих законов природы[5].

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По введенному с клавиатуры номеру месяца определить, к какому времени года он относится и какие месяцы являются для данного предыдущим и последующим. составить программу в паскале.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Klicheva_Ermachenkova1536
info46
Galiaahmatova4447
Budanov317
Мартынова_Ринатовна1657
Dato24043846
olqa27
ilyagenius
mmi15
olg53362928
oslopovavera
drevile57
pokrov777krest
Кузнецов
smokestylemos