uchpapt
?>

Составить блок-схему и написать программу в эвм вводятся по очереди координаты n точек. определить, сколько из них попадает в круг радиусом r с центром в точке (a, b

Информатика

Ответы

studiojanara
Блок-схема - в прилагаемом файле.
Программа:
var n,r,a,b,k,x,y,i:integer;
begin
readln(n,r,a,b);
k:=0;
for i:=1 to n do
 begin
 readln(x,y);
 if sqr(x-a)+sqr(y-b)<r*r then k:=k+1;
 end;
writeln('k = ',k);
end.

Пример:
3 4 1 1
2 2
-2 -3
0 0
k = 2
bogdanovaoksa
Program p1;

var
  a, b, c, s: real;

begin
  Writeln('Вычислите S поверхности параллелепипеда.');
  Writeln('Введите исходные данные:');
  Write('Длина(см)? '); Readln(a);
  Write('Ширина(см)? '); Readln(b);
  Write('Высота(см)? '); Readln(c);
  s := 2 * (a * b + b * c + c * a);
  Writeln('Площадь поверхности: ', s, ' кв.см.')
end.

Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.

program p2;
var
  ct,ck,s:real;
  kt,kk:integer;
begin
  Writeln('Вычисление стоимости покупки');
  Writeln('Введите исходные данные:');
  Write('Цена тетради(руб.)? '); Readln(ct);
  Write('Количество тетрадей? '); Readln(kt);
  Write('Цена карандашей(руб.)? '); Readln(ck);
  Write('Количество карандашей? '); Readln(kk);
  s:=ct*kt+ck*kk;
  Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.

Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.
kuchino09
Program p1;

var
  a, b, c, s: real;

begin
  Writeln('Вычислите S поверхности параллелепипеда.');
  Writeln('Введите исходные данные:');
  Write('Длина(см)? '); Readln(a);
  Write('Ширина(см)? '); Readln(b);
  Write('Высота(см)? '); Readln(c);
  s := 2 * (a * b + b * c + c * a);
  Writeln('Площадь поверхности: ', s, ' кв.см.')
end.

Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.

program p2;
var
  ct,ck,s:real;
  kt,kk:integer;
begin
  Writeln('Вычисление стоимости покупки');
  Writeln('Введите исходные данные:');
  Write('Цена тетради(руб.)? '); Readln(ct);
  Write('Количество тетрадей? '); Readln(kt);
  Write('Цена карандашей(руб.)? '); Readln(ck);
  Write('Количество карандашей? '); Readln(kk);
  s:=ct*kt+ck*kk;
  Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.

Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить блок-схему и написать программу в эвм вводятся по очереди координаты n точек. определить, сколько из них попадает в круг радиусом r с центром в точке (a, b
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lidiya08083268
Диана-Николаевна377
evageniy79
mariokhab
Дмитрий74
Агибалов428
misspodvigina
Елизавета Александр2011
sigidinv
mar1030
qadjiyevaaynura
АлександровнаВладлен243
Екатерина15
jamaltreid
Жукова_Петрович1281