santechma
?>

Склавиатуры водит число напишите программу которая вычитает из него 10, если оно отрицательно, в противном случае прибавляет к нему 10 и выводит на экран

Информатика

Ответы

artemka56rus
Program название;
var
n:integer;
begin
readln(n);
if n<0 then
n:= n-10
else
n:=n+10;
writeln(n);
end.
Columbia777

1. Данная модель - схема (или же чертёж, план) моей комнаты (на рисунке).

2. Иерархическая система - это многоклассовая (многоуровневая) система с открытой архитектурой и гибкоизменяемой конфигурацией. Пример иерархической системы - иерархия государства, иерархия должностей организации, корпорация.

Обширнее:

Иерархия государства - во главе, например, президент (руководитель). Далее - правительство, федеральное собрание -> федеральные министерства -> гос. комитеты и т.п.

Иерархия должностей организации - например, Маршал России -> Генерал армии -> Генерал-полковник -> Генерал Лейтенант и т.п.

Корпорация - руководитель -> команда управления -> высшее управленческое звено -> среднее управленческое звено и т.п..


Постройте графическую модель Вашей комнаты, указав на ней расположение всех предметов мебели, окон и
Koranna1986

Формально, количество бит для представления значений определяется двоичным логарифмом от числа значений. Здесь число десятичных цифр равно 10, значит, число возможных значений равно 10. Осталось вычислить log₂10 — получится приблизительно 3,322 бита.

Иными словами, спросите себя: в какую степень нужно возвести число 2 чтобы получить 10? Правильный ответ: число 2 в степени 3,322 приблизительно равно 10.

Если вам трудно воспринять тот факт, что число бит оказалось нецелым числом, округлите в большую сторону — получится 4 бита. Но тогда и вопрос нужно было начать словами: «Какое минимальное количество бит потребуется, чтобы...»

Нецелое число бит может иметь практический смысл в вычислениях. Например, у вас есть цветное изображение, где каждый пиксель представлен смешением красного, зелёного и синего сигнала, причём для каждого сигнала возможны 10 значений яркости. Сколько бит потребуется для представления одного пикселя? Умножаем 3,322 бита на 3 сигнала — получим 9,966 бит на пиксель. На практике вы будете использовать для представления пикселя не менее 10 бит, округлив до целого числа бит.

Но было бы неправильно сказать, что для пикселя требуется как минимум 12 бит, потому что якобы для 10 значений яркости сигнала нужно целых 4 бита.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Склавиатуры водит число напишите программу которая вычитает из него 10, если оно отрицательно, в противном случае прибавляет к нему 10 и выводит на экран
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kabinet17
NataliaBerezovskaya33
oyudina
arturusinsk5
vnolenev
olartamonov6
ksenyabobrovich7214
andrew-lev2501
Эвелина
yocrew13
kush-2640
nebo2020
Сорокина-Светлана
oskina3
Александрович