stratocasterr34
?>

Напишите программу, которая в последовательности целых чисел определяет значение наибольшего числа из всех нечетных введенных чисел. программа получает на вход целые положительные числа, количество введённых чисел неизвестно. последовательность чисел заканчивается числом 0(0- признак окончания ввода, не входит в последовательность количество введённых чисел не превышает 1000. все числа не превосходят 30000. среди введённых чисел есть хотя бы одно нечётное. программа должна вывести одно число: наибольшее из всех нечётных введённых чисел. пример работы программы: входные данные: 15, 20, 17, 0 выходные данные: 17

Информатика

Ответы

osnickyi
// PascalABC.NET 3.3

begin
var a:=ReadSeqIntegerWhile('Введите последовательность чисел: ',x->x<>0);
writeln(a.Where(x->x mod 2<>0).Max);
end.

Пример:
Введите последовательность чисел:  15 20 17 0
17
iuv61

PROGRAM ThreeNumbers;

VAR

   numberOne : DOUBLE;

   numberTwo : DOUBLE;

   numberThree : DOUBLE;

   sum : DOUBLE;

   product : DOUBLE;

   average : DOUBLE;

BEGIN

   WriteLn('Введите три числа:');

   Write('Число 1 -->');

   ReadLn(numberOne);

   Write('Число 2 -->');

   ReadLn(numberTwo);

   Write('Число 3 -->');

   ReadLn(numberThree);

   sum := numberOne + numberTwo + numberThree;

   product := numberOne * numberTwo * numberThree;

   average := (numberOne + numberTwo + numberThree) / 3.0;

   WriteLn('Сумма = ', sum:6:1);

   WriteLn('Произведение = ', product:6:1);

   WriteLn('Среднее = ', average:6:1);

END.

sn009
#include <iostream>
using namespace std;

int main() {
int a, b, c;
cout << "Введите 3 целых числа:\n";
cin >> a >> b >> c;
    cout << a << "+" << b << "+" << c << "=" << a+b+c << "\n";
cout << a << "*" << b << "*" << c << "=" << a*b*c << "\n";
cout <<"("<<a<<"+"<<b<<"+"<<c<<")/3="<<(a+b+c)/3.0<<"\n";
return 0;
}

Пример:
Введите 3 целых числа:
5 7 8
5+7+8=20
5*7*8=280
(5+7+8)/3=6.66667

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая в последовательности целых чисел определяет значение наибольшего числа из всех нечетных введенных чисел. программа получает на вход целые положительные числа, количество введённых чисел неизвестно. последовательность чисел заканчивается числом 0(0- признак окончания ввода, не входит в последовательность количество введённых чисел не превышает 1000. все числа не превосходят 30000. среди введённых чисел есть хотя бы одно нечётное. программа должна вывести одно число: наибольшее из всех нечётных введённых чисел. пример работы программы: входные данные: 15, 20, 17, 0 выходные данные: 17
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

martinson
aedunova3
gabramova
zotovinbox468
kalterbrun
Olifirenko119
inikonovich
Карапетян
kristinmk
Екатерина_Кирушев
rusvicktor
KovalenkoIL
evg-martenyuk
Голубева1440
info292