veronica1344
?>

Написать программу: протабулируйте функцию у = cos2x на промежутке [-2; 2] с шагом 0, 25 и вычислите среднее арифметическое отрицательных значений

Информатика

Ответы

dimanov
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  SeqGen(17,x->0.25*x-2).Tabulate(x->Cos(2*x)).Println(NewLine)
      .Select(t->t[1]).Where(y->y<0).Average.Println
end.

Результат
(-2,-0.653643620863612)
(-1.75,-0.936456687290796)
(-1.5,-0.989992496600445)
(-1.25,-0.801143615546934)
(-1,-0.416146836547142)
(-0.75,0.0707372016677029)
(-0.5,0.54030230586814)
(-0.25,0.877582561890373)
(0,1)
(0.25,0.877582561890373)
(0.5,0.54030230586814)
(0.75,0.0707372016677029)
(1,-0.416146836547142)
(1.25,-0.801143615546934)
(1.5,-0.989992496600445)
(1.75,-0.936456687290796)
(2,-0.653643620863612)
-0.759476651369786
Paradismebel

12

Объяснение:

Вероятно это на Pascal. Если исправить в программе ошибки, то она может выглядеть так:

var x,y,i: integer;

begin

x := 1;

y := x-4;

for i := 1 to 4 do  

   begin

       if y < 2 then x := x+4 else x:= x+2;

       if x < 8 then y:= y+1 else y := y-1;

   end;

y := y+x;

writeln (y);

end.

Итак, значения i меняются от 1 до 4

i = 1, x= 1, y = x-4 = -3, и поскольку y < 2 TRUE тогда x = x + 4 = 1 + 4 = 5

поскольку x < 8 TRUE, то y = y + 1 = -3 + 1 = -2

i = 2, x = 5, y = -2 и поскольку y < 2 TRUE, то x = x + 4 = 5 + 4 = 9

поскольку x < 8 FALSE, y = y - 1 = -2 -1 = -3

i = 3, x = 9, y =- 3 и поскольку y < 2 TRUE, то х = х + 4 = 9 + 4 = 13

поскольку x < 8 FALSE, y=y-1 = -3 - 1 = -4

i = 4, x = 9, y = -4  и поскольку y < 2 TRUE, то х = х + 4 = 13 + 4 = 17

поскольку x < 8 FALSE, y=y-1 = -4 - 1 = -5

y = y + x = -5 + 17 = 12

выводим 12, конец программы

ЗЫ: когда задаете вопрос по программированию, стоит указать язык программирования, так всем будет проще

ivanovmk1977

static void Main(string[] args)

       {

           string F;

           string[] nota = new string[7];

           nota[0] = "До";

           nota[1] = "Ре";

           nota[2] = "Ми";

           nota[3] = "Фа";

           nota[4] = "Соль";

           nota[5] = "Ля";

           nota[6] = "Си";

           Console.WriteLine("Введите ноту");

           F = Console.ReadLine();

           int Index = -1;

           for(int i=0;i<7;i++)

           {

               if(nota[i]==F)

               {

                   Index = i+2;

                   if (Index > 6) Index = Index - 7;

               }

           }

           if(Index == -1) Console.WriteLine("Нота не найдена");

           else Console.WriteLine(nota[Index]);

           Console.ReadLine();

       }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу: протабулируйте функцию у = cos2x на промежутке [-2; 2] с шагом 0, 25 и вычислите среднее арифметическое отрицательных значений
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mir5552
info6
danceplusru
Stepanovich_Makarov
pavlino-mkr
Lianchikavon
Konchenko1980
Сумарокова
abahtina582
Федор_Рауф1592
Милита1065
Nikita_Lina1305
goryavinan
Альберт Луиза1595
vdk81816778
▲