#include <iostream>
using namespace std;
int main()
{
const int N = 5;
const int M = 3;
int matrix[N][M];
for(int i = 0; i < N; i++)
{
for(int j = 0; j < M; j++)
{
matrix[i][j] = rand() % 10;
cout << matrix[i][j] << "\t";
}
cout << endl;
}
int min = matrix[0][1];
for(int i = 0; i < N; i++)
{
for(int j = 0; j < M; j++)
if((j + 1) % 2 == 0)
{
if(matrix[i][j] < min)
min = matrix[i][j];
}
}
cout << "\n" << min;
return 0;
}
Объяснение:
Кажется, еще совсем недавно наступил новый 2013 год. А знали ли Вы забавный факт о том, что 2013 год является первым годом после далекого 1987 года, в котором все цифры различны?
Теперь же Вам предлагается решить следующую задачу: задан номер года, найдите наименьший номер года, который строго больше заданного и в котором все цифры различны.
Входные данные
В единственной строке задано целое число y (1000 ≤ y ≤ 9000) — номер года.
Выходные данные
Выведите единственное целое число — минимальный номер года, который строго больше y, в котором все цифры различны. Гарантируется, что ответ существует.
Примеры
входные данные
1987
выходные данны
2013
входные данные
2013
выходные данные
2014
Поделитесь своими знаниями, ответьте на вопрос:
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
const int size = 100;
int main()
{
int fd[2];
char inf_to_send[size];
scanf("%s", inf_to_send);
pid_t p = fork();
pipe(fd);
if (p > 0) {
close(fd[0]);
write(fd[1], inf_to_send, size);
printf("Parent(%d) send str: %s\n", getpid(), inf_to_send);
close(fd[1]);
} else {
close(fd[1]);
read(fd[0], inf_to_send, size);
printf("Child(%d) received str: %s\n", getpid(), inf_to_send);
close(fd[0]);
}
}