===== PascalABC.NET =====
begin
var n := ReadInteger('n =');
var p := 1 - 1 / 2;
var i := 3;
while i <= n do
begin
p *= 1 - 1 / i;
i += 1
end;
Println(p)
end.
Объяснение:
Хороший "страдать фигней", программируя подобные задачи.
Ведь понятно, что (1 - 1/2) (1 - 1/3) ( 1 - 1/4) ... (1 - 1/n) всегда равно 1/n
В самом деле? 1/2 × 2/3 × 3/4 × 4/5 × ... (n-1)/n = 1/n, потому что соседние члены взпимно сокращаются.
Правда, задав достаточно большое n, можно убедиться, что арифметика вещественных чисел небезупречна в точности. В приведенном примере для n = 2 миллиарда получаем погрешность уже в 13-й цифре.
Поделитесь своими знаниями, ответьте на вопрос:
Пользователь вводит с клавиатуры целые положительные числа, разделяемые нажатием клавиши . признаком конца последовательности является число 0. напишите программу, которая выводит на экран сумму и среднее арифметическое чётных чисел(выполнить программу с операторов цикла while и repeat)
begin N:= 1; count:= 1; while not(N = 0) do begin read(N); if N mod 2 = 0 then begin sum:= sum + N; count:=count + 1; end; end; writeln('sum = ',sum); writeln('sr. arefm. = ',sum/count);end.