Поделитесь своими знаниями, ответьте на вопрос:
1.Рассчитать сумму кубов всех положительных значений и их количество для функции y = 3x2 + 3sin(x Составить программу для табулирования функции на промежутке [0;5] с шагом h=0, 7. На проверку прислать код программы и результат работы кода в виде скриншота окна программы с введенными входными данными. 2.Составьте программу на Паскале для заполнения массива из 100 чисел случайными значениями из диапазона от -40 до 40. Подсчитайте в этом массиве количество положительных и сумму отрицательных чисел. На проверку прислать код программы и результат работы кода в виде скриншота окна программы с введенными входными данными. 3.Заполните случайными числами в диапазоне от 1 до 10 два массива: А[1:10] и B[1:10]. Найдите и выведите на экран только те элементы этих массивов, значения которых совпадают. Например, если А[2] = В[2] = 6, то на экран надо вывести: Номер: 2 значение: 6 Если таких совпадений нет, то вывести на экран сообщение об этом. На проверку прислать код программы и результат работы кода в виде скриншота окна программы с введенными входными данными. В одномерном массиве подсчитать произведение элементов, которые не равняются 0. На проверку прислать код программы и результат работы кода в виде скриншота окна программы с введенными входными данными.
#include <stdio.h>
#include <stdlib.h>
#include <time.h>
int main(){
int arr[10],even[10], cur = 0, tmp;
srand(time(0));
puts("Source array:");
for (int i = 0; i < 10; i++){ //генерация массива +
arr[i] = rand() % 30; //отбор четных элементов
printf("%d\n", arr[i]);
if (arr[i] % 2 == 0){
even[cur] = arr[i];
cur++;
}
}
for (int i = 0; i < cur; i++) //сортировка пузырьком по убыванию
for(int j = 0; j < cur - i - 1; j++)
if (even[j+1] > even [j]){
tmp = even[j+1];
even[j+1] = even[j];
even[j] = tmp;
}
puts("Sorted array:"); //печать сортированного массива
for (int i = 0; i < cur; i++)
printf("%d\n", even[i]);
return 0;
}
Объяснение:
Компилятор gcc 8.2.0