viz-art-pnz1664
?>

Написать программу на с и на с++, вычислить расстояние между двумя точками с данными координатами (х1 у1)и (х2 у2) .я вот что-то сделала но неправильно #include #includ void main() {float x1, y1, x2, y2; cout("x1, y1, x2, y2"); cin (%f, %f, %f, %f, & x1, & y1, & x2, & y2); d: sqrt((pow (x1-x2, 2) *po(y-y2, 2)) }

Информатика

Ответы

pashyanaram

#include <iostream>

#include <cmath>

int main()

{

 float x1, y1, x2, y2;

 std::cout << "x1 :" << std::endl;

 std::cin >> x1;

 std::cout << "y1 :" << std::endl;

 std::cin >> y1 ;  

 std::cout << "x2 :" << std::endl;

 std::cin >> x2;  

 std::cout << "y2 :" << std::endl;

 std::cin >> y2;  

 float result = std::sqrt((std::pow(std::abs(x1-x2), 2) + std::pow(std::abs(y1-y2), 2)));

 std::cout << result << std::endl;

 char * temp = new char[0]();  

 std::cin >> temp;

 return 0;

}

banketvoshod
Uses graphABC;beginsetwindowsize(600,500);setbrushcolor(clMedGray);Ellipse(320,30,490,400);Ellipse(120,30,300,400);setbrushcolor(clCream);Ellipse(335,40,480,380);Ellipse(140,40,280,380);setbrushcolor(clMedGray);Ellipse(100,430,500,130);setbrushcolor(clNavy);Ellipse(250,240,200,310);Ellipse(350,240,400,310);setbrushcolor(clwhite);Ellipse(240,270,220,300);Ellipse(360,270,380,300);
setbrushcolor(clblack);Ellipse(270,330,330,370);line(300,370,300,400);Arc(300,280,120,220,-40);
line(50,350,200,350);line(30,340,190,340);line(10,330,180,330);
line(410,330,570,330);line(400,340,560,340);line(390,350,550,350);
line(240,230,220,150);line(230,230,180,80);line(220,230,180,150);
line(360,230,380,150);line(370,230,430,80);line(380,230,430,150);
end.
vasilevich-F

Решение перебором АДЛТДТАТ

Объяснение:

Для начала можно понять, что первая точка и продолжение подходит только для буквы А и в итоге остаётся: -...-..--..-.--, дальше у нас 2 варианта:

1) АД.-..--..-.-- >> 1 - АДА..--..-.-- 2 - АДЛ--..-.--

2)АТ...-..--..-.-- >> АТЖ..--..-.--

Продолжаем перебирать:

1)  АДА..--..-.--  больше нельзя продолжить т.к букв из 2 точек вначале нету.

2) АДЛ--..-.--  >>   АДЛТ-..-.--  >> 1)АДЛТД-.-- 2)АДЛТТ..-.--

3) АТЖ..--..-.--  >> нельзя продолжить из за двух точек.

Продолжаем:

1)АДЛТД-.-- >> АДЛТДТАТ - это ответ

2)АДЛТТ..-.-- нельзя продолжить из за двух точек.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на с и на с++, вычислить расстояние между двумя точками с данными координатами (х1 у1)и (х2 у2) .я вот что-то сделала но неправильно #include #includ void main() {float x1, y1, x2, y2; cout("x1, y1, x2, y2"); cin (%f, %f, %f, %f, & x1, & y1, & x2, & y2); d: sqrt((pow (x1-x2, 2) *po(y-y2, 2)) }
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Talikova164
Дарья16
chaa140
Anatolevich667
delfa-r6289
rebet61
Yurevich1291
tat72220525
mbrilliantova
leeka152522
Boris1247
Чиркина999
Оксана
Меладзе_Владимир1695
asviridova07194