director3
?>

Напишите программу: посчитать количество четных цифр в числе, введенном с клавиатуры. pascal

Информатика

Ответы

Belik-elena20111
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (n,k):=(Abs(ReadInteger('n=')),0);
  if n=0 then k:=1
  else
    while n>0 do begin
      if (n mod 10).IsEven then k+=1;
      n:=n div 10
      end;
  Writeln('Четных цифр: ',k)
end.

Пример
n= -623451
Четных цифр: 3
mouse-0211fsb3509
Var
a, b, k : integer;
begin
k := 0;
write('введите число: ');
readln(a);
while a <> 0 do
begin
b := a mod 10;
if b mod 2 = 0 then inc(k);
a := a div 10
Writeln ('Чётных: ', a);
end;
end.
Okunev1034
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var n:=ReadInteger('Количество элементов в массиве: ');
  var a:=ArrRandom(n,-50,50);
  a.Println(',');
  Writeln('Четные элементы: ');
  var i:=1;
  while i<n do begin Write(a[i],' '); Inc(i,2) end;
  Writeln;
  Writeln('Нечетные элементы: ');
  i:=0;
  while i<n-1 do begin Write(a[i],' '); Inc(i,2) end;
  Writeln
end.

Тестовое решение:
Количество элементов в массиве:  10
15,-18,-29,-25,46,21,-8,-17,-9,15
Четные элементы:
-18 -25 21 -17 15
Нечетные элементы:
15 -29 46 -8 -9
taksa6444
1. При использовании палитры из 2^24 цветов для хранения цвета 1 пикселя используется 24 бита = 3 байта.
Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт.
X = 8*(K*3/1024 + 128)+2.5*1024
2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта.
Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт.
X = 20*(K*2/1024 + 128)
8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128)
К = 65536 (количество пикселей в рисунке)
X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт = 
 20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу: посчитать количество четных цифр в числе, введенном с клавиатуры. pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

reinish23
egoryuzbashev
Leobed917670
Илья_Ветклиники1655
lmedintseva6
Varezka86179
beglovatatiyana
girra
Денис1619
vadimkayunusov
rada8080
kulibabad566
irschacha
art-03857