avolodyaev
?>

Написать программу для вычисления выражения: s=1! +2! +3! ++15!

Информатика

Ответы

voen-torg
Program pr1;
const n=8;
function factorial(n:integer):integer;
begin
if (n<=1) then factorial:=1
else factorial:=n*factorial(n-1);
end;
begin
WriteLn('n!=',factorial(n));
end.
Sergeevich-Drugov1513
Действия выполняются в обратном порядке. Последнее действие было "из нечетных цифр вычитается,а к четным прибавляется 1".Из нечетных цифр вычли 1 и они стали четными (при вычитании единицы меняется четность), с четными все то же самое, только наоборот. Значит нужно ко всем четным цифрам прибавить 1, а от нечетных отнять 1, тогда получится исходная цифра.3216 -> 2307.Итак, знаем, что на предпоследнем шаге было число 2307. Идем еще на шаг назад. "цифры,занимающие четные разряды (нумерация разрядов ведется справа налево начиная с нуля) циклически сдвигаются вправо,а нечетные - влево на количество позиций, равных номеру разряда". Опять же, делаем наоборот. Цифры на четных разрядах сдвигаем влево, а нечетные - вправо. Количество позиций не меняется, только направление.2307 -> 5117Пароль почты Васи: 5117.Традиционно проверочка...Имеем 5117.Семь сдвигаем вправо на 0.7 -> 7.Один сдвигаем влево на 1.1 -> 0.Один сдвигаем вправо на 2.1 -> 3.Пять сдвигаем влево на 3.5 -> 2.Получаем 2307.От нечетных цифр отнимаем 1, а к четным прибавляем.Получаем 3216. Что и было дано изначально.
aksmobile
 математике принято классифицировать переменные в соответствии с некоторыми важными характеристиками. Производится строгое разграничение между вещественными, комплексными и логическими переменными, между переменными, представляющими отдельные значения и множество значений, и т. д. При обработке данных на ЭВМ такая классификация еще более важна. В любом алгоритмическом языке каждая константа, переменная, выражение или функция бывают определенного типа.В языке Pascal существует правило: тип явно задается в описании переменной или функции, которое предшествует их использованию. Концепция типа языка Pascal имеет следующие основные свойства:1) любой тип данных определяет множество значений, к которому принадлежит константа, которые может принимать переменная или выражение либо вырабатывать операция или функция;2) тип значения, задаваемого константой, переменной или выражением, можно определить по их виду или описанию;3) каждая операция или функция требуют аргументов фиксированного типа и выдают результат фиксированного типа.Отсюда следует, что транслятор может использовать информацию о типах для проверки вычислимости и правильности различных конструкций.Тип определяет:1) возможные значения переменных, констант, функций, выражений, принадлежащих к данному типу;2) внутреннюю форму представления данных в ЭВМ;3) операции и функции, которые могут выполняться над величинами, принадлежащими к данному типу.Следует заметить, что обязательное описание типа приводит к избыточности в тексте программ, но такая избыточность является важным вс средством разработки программ и рассматривается как необходимое свойство современных алгоритмических языков высокого уровня.В языке Pascal существуют скалярные и структурированные типы данных. К скалярным типам относятся стандартные типы и типы, определяемые пользователем. Стандартные типы включают целые, действительные, символьный, логические и адресный типы.Целые типы определяют константы, переменные и функции, значения которых реализуются множеством целых чисел, допустимых в данной ЭВМ.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для вычисления выражения: s=1! +2! +3! ++15!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sergey3699
sky-elena712558
levsha-27509
Nikolaevna382
konnovakat1
Исмагилова_Саният
Chikichev456
Shipoopi8
Vetroff-11
swetlanafatinia7323
Стяжкин
vikola2008
Freelifecool797
pbttehnology
luxoutlet