MikhailSvetlana
?>

Написать программу на c# работа с текстовыми файлами: имеется текстовый файл. выяснить, имеется ли в нем строка, начинающаяся с буквы «т». если да, то определить номер первой из таких строк. условие: текстовый файл для заранее создать в текстовом редакторе

Информатика

Ответы

ietishkin
Using System;
using System.IO;

internal class Program
{
    public const string FILE = "test.txt";

    private static void Main()
    {
        try
        {
            using (var sr = File.OpenText(FILE))
            {
                string line;
                for (var i = 0; (line = sr.ReadLine()) != null; i++)
                {
                    if (!string.IsNullOrWhiteSpace(line) && line.Trim()[0] == 'т')
                    {
                        Console.WriteLine($"Строка {i} = {line}");
                        break;
                    }
                }
            }
        }
        catch(Exception e)
        {
            Console.WriteLine(e);
        }
        finally
        {
            Console.ReadLine();
        }
    }
}
сергеевич1958
Uses  crt;
var  item, rub, doll: real; 
  job: integer;
begin   
writeln('Введите курс ру по отношению к дол: '); 
read(item);//Вводим курс рубль-доллар 
writeln('Перевести из (рубля в доллар(2)) или (доллар в рубль(1))?'); 
read(job);//Вводим режим 
case job of
  2:      begin       
writeln('Введите кол-во рублей: ');       
 read(rub);//Вводим рубль       
 rub := rub / item;       
writeln('doll = ',rub);
end;
1:      begin       
writeln('Введите кол- во долларов: ');       
read(doll);//Вводим доллар       
doll := doll * item;       
 writeln('rub = ',doll);
end;
 end;    
 end.
simplexsol
Итак первые два символа кодируются кодовыми словами 0 и 10. Найдём для остав­ших­ся трех сим­во­лов наи­бо­лее ко­рот­кое пред­став­ле­ние, удо­вле­тво­ря­ю­щее усло­вию Фано. Из двузначных чисел можно взять 11, но тогда невозможно подобрать трехзначное число для четвертого символа, по этому не берем. Единственное подходящее трехзначное число - 110 (111 не подходит по той же причине. что и 11). Аналогично выбираем числа 1110 и 11110. 
В итоге получается ряд: 0, 10, 110, 1110, 11110.
Общая длина = 1+2+3+4+5=15 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на c# работа с текстовыми файлами: имеется текстовый файл. выяснить, имеется ли в нем строка, начинающаяся с буквы «т». если да, то определить номер первой из таких строк. условие: текстовый файл для заранее создать в текстовом редакторе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fil-vasilij90
elena-novikova-1992
Shirochkingames
rsd737
muzeynizhn
Zashchitin Denis
bondarev05071962
travkinadjey31
adminkuncevo
Fruktova Gazaryan
ShafetdinovAndrei
titancore
kassel1b
ranocchio6
Sacharov84