Tatarnikova1507
?>

Необходимо ввести некоторое целое число и если оно четное уменьшить его в 2 раза.составить программу на паскаль

Информатика

Ответы

artashhovhan
Var
a:longint;
begin
read(a);
if (a mod 2 = 0) then
a:= a div 2;
writeln(a);
end.
kazanoop
Леонард Эйлер (1707-1783) — математик, механик, физик и астроном. По происхождению швейцарец. Идеальный математик 18 века - так часто называют Эйлера. Он был одним из самых великих математиков всех времен. Он разработал основы современной теории чисел и алгебры, топологии, исчисления вероятности и комбинаторики, интегрального исчисления, теории дифференциального исчисления и дифференциальной геометрии, вариационного исчисления, открыл связь между тригонометрическими и экспоненциальными функциями. Леонард Эйлер разработал учения гидродинамики и аэрогидродинамики, создал основы теории гироскопа. Он был гениальным естествоиспытателем, замечательным учителем и наставником.
Алина1564
   Второе поколение.
    Полупроводниковая элементная база. Значительно повышается надежность и производительность, снижаются габариты и потребляемая мощность. Развитие средств ввода/вывода, внешней памяти. Ряд прогрессивных архитектурных решений и дальнейшее развитие технологии программирования- режим разделения времени и режим мультипрограммирования (совмещение работы центрального процессора по обработке данных и каналов ввода/вывода, а также распараллеливания операций выборки команд и данных из памяти)
    В рамках второго поколения четко стала проявляться дифференциация ЭВМ на малые, средние и большие. Существенно расширилась сфера применения ЭВМ на решение задач - планово - экономических, управления производственными процессами и др.
    Создаются автоматизированные системы управления (АСУ) предприятиями, целыми отраслями и технологическими процессами (АСУТП). Конец 50-х годов характеризуется появлением целого ряда проблемно-ориентированных языков программирования высокого уровня (ЯВУ): FORTRAN, ALGOL-60 и др. Развитие ПО получило в создании библиотек стандартных программ на различных языках программирования и различного назначения, мониторов и диспетчеров для управления режимами работы ЭВМ, планированием ее ресурсов, заложивших концепции операционных систем следующего поколения.    

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Необходимо ввести некоторое целое число и если оно четное уменьшить его в 2 раза.составить программу на паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alekseymedvedev1981
Васенкова204
de1979nis
sse1105
slava-m-apt
askorikova
egorova90356684858370
saint158
Galina-Marat1096
Коновалова
yaart-klementiev29
departed744
spikahome
natalyazx151092814
lirene